summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-09-27 14:43:34 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-09-27 14:43:34 +0000
commite5b081335e1a976bb3cd6abe9327f9d0d0dd7ecc (patch)
treef000c718f28f2877e4213d8955344a36f7e11912 /target/linux/ramips/image
parent39c57eeb318a630884d790af27824c833617d2e0 (diff)
downloadmaster-31e0f0ae-e5b081335e1a976bb3cd6abe9327f9d0d0dd7ecc.tar.gz
master-31e0f0ae-e5b081335e1a976bb3cd6abe9327f9d0d0dd7ecc.tar.bz2
master-31e0f0ae-e5b081335e1a976bb3cd6abe9327f9d0d0dd7ecc.zip
ramips: Ralink RT305x, support for Prolink PWH2004 (Abocom5205)
The attached patch adds a preliminary support for Prolink PWH2004 board (Ralink RT305x based). LAN and flash appear to work. However, the USB port and WLAN I have not managed to activate properly yet, but that problem appears to be present with other rt305x targets as well(?). Signed-off-by: Esa Hyytia <esa at netlab.tkk.fi> SVN-Revision: 23129
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 03be7647ce..acd328317c 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -88,6 +88,10 @@ define Image/Build/Profile/FONERA20N
$(call Image/Build/Template/GENERIC_8M,$(1),fonera20n,FONERA20N)
endef
+define Image/Build/Template/PWH2004
+ $(call Image/Build/Template/GENERIC_8M,$(1),pwh2004,PWH2004)
+endef
+
define Image/Build/Profile/V22RW2X2
$(call Image/Build/Template/GENERIC_4M,$(1),v22rw-2x2,V22RW-2X2)
endef
@@ -114,6 +118,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/DIR300B1,$(1))
$(call Image/Build/Profile/FONERA20N,$(1))
$(call Image/Build/Profile/V22RW2X2,$(1))
+ $(call Image/Build/Profile/PWH2004,$(1))
$(call Image/Build/Profile/WHRG300N,$(1))
$(call Image/Build/Profile/WCR150GN,$(1))
endef