summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorMichael Lee <igvtee@gmail.com>2016-05-28 22:22:10 +0800
committerJohn Crispin <john@phrozen.org>2016-06-13 22:51:43 +0200
commit9a4935687d6d79e0eeae37204794fc68e17c8b68 (patch)
treec4642ab6221cf968da84f6926d3bfe4e575c8e4b /target/linux/ramips/image
parent49b74218362eca516af5a4697a00cd4fa5d3640b (diff)
downloadmaster-31e0f0ae-9a4935687d6d79e0eeae37204794fc68e17c8b68.tar.gz
master-31e0f0ae-9a4935687d6d79e0eeae37204794fc68e17c8b68.tar.bz2
master-31e0f0ae-9a4935687d6d79e0eeae37204794fc68e17c8b68.zip
ramips: add support for DuZun DM06
DuZun DM06 is a develop board based on mt7628 64M RAM, 8M SPI Flash, 1 WAN, 1 LAN. wm8960 codec with line out, line in and speaker output. Signed-off-by: Michael Lee <igvtee@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7628.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7628.mk b/target/linux/ramips/image/mt7628.mk
index 8274e11f17..fa7d1e77f2 100644
--- a/target/linux/ramips/image/mt7628.mk
+++ b/target/linux/ramips/image/mt7628.mk
@@ -25,3 +25,11 @@ define Device/wrtnode2p
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
endef
TARGET_DEVICES += wrtnode2p
+
+define Device/duzun-dm06
+ DTS := DUZUN-DM06
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ DEVICE_TITLE := DuZun DM06
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+TARGET_DEVICES += duzun-dm06