summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-12-01 22:48:42 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-12-01 22:48:42 +0000
commit62d18e9f9a9b78b60f17344b731ad993b216f2ab (patch)
treeb3a0ae301614b6a7e634f59816d0958fecde3c2a /target/linux/ramips/image
parent2dd79d55c77e400a8dacf79a10d4700f31f95db5 (diff)
downloadmaster-31e0f0ae-62d18e9f9a9b78b60f17344b731ad993b216f2ab.tar.gz
master-31e0f0ae-62d18e9f9a9b78b60f17344b731ad993b216f2ab.tar.bz2
master-31e0f0ae-62d18e9f9a9b78b60f17344b731ad993b216f2ab.zip
ramips: fix Asus RT-N15 board support
Fix Asus RT-N15 flash partitions and make an image. Signed-off-by: Roman Yeryomin <roman@advem.lv> SVN-Revision: 29381
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 7f0ef00e46..24f59663cc 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -258,6 +258,17 @@ define Image/Build/Profile/Default
endef
endif
+
+define Image/Build/Profile/RTN15
+ $(call Image/Build/Template/GENERIC_4M,$(1),rt-n15,RT-N15)
+endef
+
+ifeq ($(CONFIG_RALINK_RT288X),y)
+define Image/Build/Profile/Default
+ $(call Image/Build/Profile/RTN15,$(1))
+endef
+endif
+
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
endef