summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-08-11 17:00:36 +0200
committerFelix Fietkau <nbd@nbd.name>2016-08-11 17:07:37 +0200
commit592c0a1cd226b7c5a90fb2c3127ac1e0743c22fd (patch)
tree63021845ac0344c67f26d26df199c053f819af64 /target/linux/ramips/image
parent9d56ec6244e516fd80f8500aaa081c39ffeccf86 (diff)
downloadmaster-31e0f0ae-592c0a1cd226b7c5a90fb2c3127ac1e0743c22fd.tar.gz
master-31e0f0ae-592c0a1cd226b7c5a90fb2c3127ac1e0743c22fd.tar.bz2
master-31e0f0ae-592c0a1cd226b7c5a90fb2c3127ac1e0743c22fd.zip
ramips: fix legacy image build
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 44508b630c..6116a53bf2 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -197,7 +197,7 @@ define BuildFirmware/Seama/squashfs
$(call MkImageLzmaDtb,$(2),$(3),$(5))
$(eval output_name=$(IMG_PREFIX)-$(2)-$(1)-sysupgrade.bin)
cat $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/root.$(1) > $(KDIR)/img_$(2).$(1).tmp
- if [ `stat -c%s "$(KDIR)/img_$(2).$(1).tmp"` -gt $$$$(($(5) - 64)) ]; then \
+ if [ `stat -c%s "$(KDIR)/img_$(2).$(1).tmp"` -gt $(5) ]; then \
echo "Warning: $(KDIR)/img_$(2).$(1).tmp is too big" >&2; \
else \
dd if=$(KDIR)/vmlinux-$(2).bin.lzma of=$(KDIR)/vmlinux-$(2).bin.lzma.padded bs=64k conv=sync; \
@@ -269,8 +269,7 @@ ifeq ($(SUBTARGET),mt7688)
include mt7688.mk
endif
-
-ifndef TARGET_DEVICES
+ifdef LEGACY_DEVICES
#
# Generic Targets - only needed for legacy image building code
#
@@ -294,8 +293,12 @@ endef
define Image/Build
$(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
- $(call Image/Build/Profile/$(PROFILE),$(1))
endef
+
+define Image/Build/Profile
+ $(call Image/Build/Profile/$(1),$(2))
+endef
+
endif
$(eval $(call BuildImage))