summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-08-29 10:37:43 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-08-29 10:37:43 +0000
commit1617f226a906f82ce6516e3e5a1e0909d8aa8806 (patch)
tree3cc5963071f00cbcd2b187c2b32adef98c5c7317 /target/linux/ramips/image
parentbb0785880acf5a681ab5df492b60636c0eddceab (diff)
downloadmaster-31e0f0ae-1617f226a906f82ce6516e3e5a1e0909d8aa8806.tar.gz
master-31e0f0ae-1617f226a906f82ce6516e3e5a1e0909d8aa8806.tar.bz2
master-31e0f0ae-1617f226a906f82ce6516e3e5a1e0909d8aa8806.zip
ramips: Add support for 8devices Carambola dev board.
Add support for 8devices Carambola dev board. The Carambola is a small RT3050-based development board with two ethernet ports, on-board chip antenna, usb and plenty of accessible gpio ports, sold by 8devices. Signed-off-by: Tobias Diedrich <ranma+openwrt@tdiedrich.de> SVN-Revision: 33303
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index e43b501ee4..d1204f3e29 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -403,6 +403,10 @@ define Image/Build/Profile/BC2
$(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,bc2,BC2,ttyS1,57600,phys)
endef
+define Image/Build/Profile/CARAMBOLA
+ $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,carambola,CARAMBOLA,ttyS1,115200,phys)
+endef
+
define Image/Build/Profile/DIR300B1
$(call Image/Build/Template/$(fs_squash)/$(1),DIR300B1,dir-300-b1,DIR-300-B1,wrgn23_dlwbr_dir300b)
$(call Image/Build/Template/$(fs_squash)/$(1),DIR300B1,dir-600-b1,DIR-600-B1,wrgn23_dlwbr_dir600b)
@@ -538,6 +542,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/ALL5002,$(1))
$(call Image/Build/Profile/ARGUS_ATP52B,$(1))
$(call Image/Build/Profile/BC2,$(1))
+ $(call Image/Build/Profile/CARAMBOLA,$(1))
$(call Image/Build/Profile/DIR300B1,$(1))
$(call Image/Build/Profile/DIR615H1,$(1))
$(call Image/Build/Profile/DAP1350,$(1))