summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-09-09 00:57:31 +0200
committerDaniel Golle <daniel@makrotopia.org>2016-09-09 02:38:06 +0200
commit083ef3fefecd024b2b9cdc496e1f7811c225041e (patch)
treed118da4d8e914c0bd0dc1ee4721fb797a9c6d55c /target/linux/ramips/image
parent943cf08fb72ab87b8a5ccb7752d36b6b452ac09f (diff)
downloadmaster-31e0f0ae-083ef3fefecd024b2b9cdc496e1f7811c225041e.tar.gz
master-31e0f0ae-083ef3fefecd024b2b9cdc496e1f7811c225041e.tar.bz2
master-31e0f0ae-083ef3fefecd024b2b9cdc496e1f7811c225041e.zip
ramips: add support for Mercury MAC1200R v2
MT7628AN + MT7612E, 8MB SPI flash, 64MB DDR RAM reset button GPIO is still missing (anyone?) bootloader password is 'slp' Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7628.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7628.mk b/target/linux/ramips/image/mt7628.mk
index fa7d1e77f2..0647acf3ad 100644
--- a/target/linux/ramips/image/mt7628.mk
+++ b/target/linux/ramips/image/mt7628.mk
@@ -33,3 +33,10 @@ define Device/duzun-dm06
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
endef
TARGET_DEVICES += duzun-dm06
+
+define Device/mac1200r-v2
+ DTS := MAC1200RV2
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ DEVICE_TITLE := Mercury MAC1200R v2.0
+endef
+TARGET_DEVICES += mac1200r-v2