summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2016-06-12 23:46:35 +0200
committerJohn Crispin <john@phrozen.org>2016-06-13 22:51:43 +0200
commit01fb393c6728d922ffd394dffa455fa6bc459cfa (patch)
tree19eff716213d4aaebc43fcc970cf125bf29073d1 /target/linux/ramips/image
parent75af98123973e1abb919213fb7c365bfaf322610 (diff)
downloadmaster-31e0f0ae-01fb393c6728d922ffd394dffa455fa6bc459cfa.tar.gz
master-31e0f0ae-01fb393c6728d922ffd394dffa455fa6bc459cfa.tar.bz2
master-31e0f0ae-01fb393c6728d922ffd394dffa455fa6bc459cfa.zip
ramips/image: Add Archer C50 to mt7620 Makefile
Signed-off-by: Henryk Heisig <hyniu@o2.pl>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 935f755923..33f94a48e9 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -50,6 +50,15 @@ define Device/ArcherC20i
endef
TARGET_DEVICES += ArcherC20i
+define Device/ArcherC50
+ DTS := ArcherC50
+ KERNEL := $(KERNEL_DTB)
+ KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC50 -c
+ IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC50 -j -r $(KDIR)/root.squashfs
+ DEVICE_TITLE := TP-Link ArcherC50
+endef
+TARGET_DEVICES += ArcherC50
+
ex2700_mtd_size=3866624
define Device/ex2700
DTS := EX2700