summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7628.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-04-01 07:11:48 +0000
committerJohn Crispin <john@openwrt.org>2016-04-01 07:11:48 +0000
commit79d02229cc12c415007ec4346425016622ec449b (patch)
tree15f41cd0e3d0073858f4e4f4d971ae7ab3dd0f46 /target/linux/ramips/image/mt7628.mk
parent12334f58fe6370441fcfe90b9dd917b33bb127dc (diff)
downloadmaster-31e0f0ae-79d02229cc12c415007ec4346425016622ec449b.tar.gz
master-31e0f0ae-79d02229cc12c415007ec4346425016622ec449b.tar.bz2
master-31e0f0ae-79d02229cc12c415007ec4346425016622ec449b.zip
ramips: move different subtarget image generation to separate makefiles to improve maintainability
- all subtarget specific defines are in their own files - common defines left in main Makefile - each subtarget makefile idefed with SUBTARGET - all subtargets compile tested - few seems to be broken/unneeded things marked with FIXME Signed-off-by: Roman Yeryomin <roman@advem.lv> SVN-Revision: 49104
Diffstat (limited to 'target/linux/ramips/image/mt7628.mk')
-rw-r--r--target/linux/ramips/image/mt7628.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7628.mk b/target/linux/ramips/image/mt7628.mk
new file mode 100644
index 0000000000..1e6b06c82c
--- /dev/null
+++ b/target/linux/ramips/image/mt7628.mk
@@ -0,0 +1,17 @@
+#
+# MT7628 Profiles
+#
+
+Image/Build/Profile/MIWIFI-NANO=$(call BuildFirmware/Default16M/$(1),$(1),miwifi-nano,MIWIFI-NANO)
+Image/Build/Profile/MT7628=$(call BuildFirmware/Default4M/$(1),$(1),mt7628,MT7628)
+Image/Build/Profile/WRTNODE2P=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode2p,WRTNODE2P)
+
+define Image/Build/Profile/Default
+ $(call Image/Build/Profile/MIWIFI-NANO,$(1))
+ $(call Image/Build/Profile/MT7628,$(1))
+ $(call Image/Build/Profile/WRTNODE2P,$(1))
+endef
+
+define Image/Build/Profile/MiwifiNano
+ $(call Image/Build/Profile/MIWIFI-NANO,$(1))
+endef