summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-06 10:11:29 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-06 10:12:37 +0200
commit201dbb9fe8f61572d66f02942c4482af9b4f2f0c (patch)
tree95f7422d381f2bad20fe2239fa585f025536b027 /target/linux/ramips/image/mt7621.mk
parentad430c1080fa2096d02b054115bd806af4906aea (diff)
downloadmaster-31e0f0ae-201dbb9fe8f61572d66f02942c4482af9b4f2f0c.tar.gz
master-31e0f0ae-201dbb9fe8f61572d66f02942c4482af9b4f2f0c.tar.bz2
master-31e0f0ae-201dbb9fe8f61572d66f02942c4482af9b4f2f0c.zip
ramips: fix build error in ubnt-erx initramfs factory image
Build initramfs kernel image, but skip factory image if initramfs size is too big. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 31752446ac..2795eb13f6 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -12,7 +12,7 @@ define Build/seama-seal
endef
define Build/ubnt-erx-factory-image
- if [ -e $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) ]; then \
+ if [ -e $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) -a "$$(stat -c%s $@)" -lt "$(KERNEL_SIZE)" ]; then \
echo '21001:6' > $(1).compat; \
$(TAR) -cf $(1) --transform='s/^.*/compat/' $(1).compat; \
\
@@ -30,6 +30,8 @@ define Build/ubnt-erx-factory-image
$(TAR) -rf $(1) --transform='s/^.*/version.tmp/' $(1).version; \
\
$(CP) $(1) $(BIN_DIR)/; \
+ else \
+ echo "WARNING: initramfs kernel image too big, cannot generate factory image" >&2; \
fi
endef
@@ -155,8 +157,7 @@ define Device/ubnt-erx
KERNEL_SIZE := 3145728
KERNEL := $(KERNEL_DTB) | uImage lzma
IMAGES := sysupgrade.tar
- KERNEL_INITRAMFS := $$(KERNEL) | check-size $$(KERNEL_SIZE) | \
- ubnt-erx-factory-image $(KDIR)/tmp/$$(KERNEL_INITRAMFS_PREFIX)-factory.tar
+ KERNEL_INITRAMFS := $$(KERNEL) | ubnt-erx-factory-image $(KDIR)/tmp/$$(KERNEL_INITRAMFS_PREFIX)-factory.tar
IMAGE/sysupgrade.tar := sysupgrade-nand
DEVICE_TITLE := Ubiquiti EdgeRouter X
DEVICE_PACKAGES := -kmod-mt76 -kmod-rt2800-pci -kmod-cfg80211 -wpad-mini -iwinfo