summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-04-09 10:24:36 +0000
committerJohn Crispin <john@openwrt.org>2016-04-09 10:24:36 +0000
commit133f890a12db957d3a5584b5f8b8912c89bb9ee2 (patch)
tree0c262aa7aa71f2548e4ea45f9b710d7bbab7d836 /target/linux/ramips/image/mt7621.mk
parenta9466914f5c27e5f9c47495017d59ada402e7897 (diff)
downloadmaster-31e0f0ae-133f890a12db957d3a5584b5f8b8912c89bb9ee2.tar.gz
master-31e0f0ae-133f890a12db957d3a5584b5f8b8912c89bb9ee2.tar.bz2
master-31e0f0ae-133f890a12db957d3a5584b5f8b8912c89bb9ee2.zip
ramips: mt7621: add a device to TARGET_DEVICES after it's definition
Signed-off-by: Roman Yeryomin <roman@advem.lv> SVN-Revision: 49124
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk16
1 files changed, 12 insertions, 4 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 76b4e484bb..628954ff50 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -33,29 +33,29 @@ define Build/ubnt-erx-factory-image
fi
endef
-ifeq ($(SUBTARGET),mt7621)
- TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 ubnt-erx witi wf-2881 zbt-wg2626
-endif
-
define Device/mt7621
DTS := MT7621
IMAGE_SIZE := $(ralink_default_fw_size_4M)
endef
+TARGET_DEVICES += mt7621
define Device/wsr-600
DTS := WSR-600
IMAGE_SIZE := $(ralink_default_fw_size_16M)
endef
+TARGET_DEVICES += wsr-600
define Device/re6500
DTS := RE6500
endef
+TARGET_DEVICES += re6500
define Device/wsr-1166
DTS := WSR-1166
IMAGE/sysupgrade.bin := trx | pad-rootfs
IMAGE_SIZE := $(ralink_default_fw_size_16M)
endef
+TARGET_DEVICES += wsr-1166
define Device/dir-860l-b1
DTS := DIR-860L-B1
@@ -71,30 +71,36 @@ define Device/dir-860l-b1
seama-seal -m "signature=wrgac13_dlink.2013gui_dir860lb" | \
check-size $$$$(IMAGE_SIZE)
endef
+TARGET_DEVICES += dir-860l-b1
define Device/firewrt
DTS := FIREWRT
IMAGE_SIZE := $(ralink_default_fw_size_16M)
endef
+TARGET_DEVICES += firewrt
define Device/pbr-m1
DTS := PBR-M1
IMAGE_SIZE := $(ralink_default_fw_size_16M)
endef
+TARGET_DEVICES += pbr-m1
define Device/sap-g3200u3
DTS := SAP-G3200U3
endef
+TARGET_DEVICES += sap-g3200u3
define Device/witi
DTS := WITI
IMAGE_SIZE := $(ralink_default_fw_size_16M)
endef
+TARGET_DEVICES += witi
define Device/zbt-wg2626
DTS := ZBT-WG2626
IMAGE_SIZE := $(ralink_default_fw_size_16M)
endef
+TARGET_DEVICES += zbt-wg2626
define Device/wf-2881
DTS := WF-2881
@@ -105,6 +111,7 @@ define Device/wf-2881
KERNEL := $(KERNEL_DTB) | pad-offset 131072 64 | uImage lzma
IMAGE/sysupgrade.bin := append-kernel | append-ubi | check-size $$$$(IMAGE_SIZE)
endef
+TARGET_DEVICES += wf-2881
define Device/ubnt-erx
DTS := UBNT-ERX
@@ -116,6 +123,7 @@ define Device/ubnt-erx
ubnt-erx-factory-image $(KDIR)/tmp/$$(KERNEL_INITRAMFS_PREFIX)-factory.tar
IMAGE/sysupgrade.tar := sysupgrade-nand
endef
+TARGET_DEVICES += ubnt-erx
# FIXME: is this still needed?
define Image/Prepare