summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorMichael Lee <igvtee@gmail.com>2016-05-02 11:57:40 +0800
committerJohn Crispin <john@phrozen.org>2016-07-11 14:19:47 +0200
commitc3e420f28cf1ed229753f94bafdb0d5851748af3 (patch)
tree2b023931fbd0c874554460f67ae2a65bbbc0e400 /target/linux/ramips/image/mt7620.mk
parent36d98e6c7a4fdfc929bdec0540c6071ee117275b (diff)
downloadmaster-31e0f0ae-c3e420f28cf1ed229753f94bafdb0d5851748af3.tar.gz
master-31e0f0ae-c3e420f28cf1ed229753f94bafdb0d5851748af3.tar.bz2
master-31e0f0ae-c3e420f28cf1ed229753f94bafdb0d5851748af3.zip
ramips: Add support for D-Link DCH-M225
D-Link DCH-M225 is based on Mediatek MT7620 with 64MB ram, 8MB flash, 3.5mm audio out support. but no ethernet and usb ports. so you must default enable wifi. Signed-off-by: Michael Lee <igvtee@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index b1afb82c00..8e1346ded2 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -41,6 +41,15 @@ define Build/elecom-header
$(STAGING_DIR_HOST)/bin/tar -cf $@ -C $(KDIR) v_0.0.0.bin v_0.0.0.md5
endef
+define Build/seama
+ $(STAGING_DIR_HOST)/bin/seama -i $@ $(1)
+ mv $@.seama $@
+endef
+
+define Build/seama-seal
+ $(call Build/seama,-s $@.seama $(1))
+endef
+
define Device/ArcherC20i
DTS := ArcherC20i
KERNEL := $(KERNEL_DTB)
@@ -413,3 +422,22 @@ define Device/tiny-ac
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
endef
TARGET_DEVICES += tiny-ac
+
+dch_m225_mtd_size=7012352
+define Device/dch-m225
+ DTS := DCH-M225
+ IMAGES += factory.bin
+ IMAGE_SIZE := $(dch_m225_mtd_size)
+ IMAGE/sysupgrade.bin := \
+ append-kernel | pad-offset 65536 64 | append-rootfs | \
+ seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
+ pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := \
+ append-kernel | pad-offset 65536 64 | append-rootfs | pad-rootfs -x 64 | \
+ seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
+ seama-seal -m "signature=wapn22_dlink.2013gui_dap1320b" | \
+ check-size $$$$(IMAGE_SIZE)
+ DEVICE_TITLE := D-Link DCH-M225
+ DEVICE_PACKAGES := kmod-mt76
+endef
+TARGET_DEVICES += dch-m225