summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-03 09:56:35 +0200
committerMathias Kresin <dev@kresin.me>2016-09-03 09:56:35 +0200
commit28110727f1d513a6c4c13aa87ecb606aa5d306eb (patch)
tree395f63bd9844aa4228c041ea47fd2e0deac7befd /target/linux/ramips/image/mt7620.mk
parent05ab2323ffa4c630934e3d0b27a2516b26c1c161 (diff)
downloadmaster-31e0f0ae-28110727f1d513a6c4c13aa87ecb606aa5d306eb.tar.gz
master-31e0f0ae-28110727f1d513a6c4c13aa87ecb606aa5d306eb.tar.bz2
master-31e0f0ae-28110727f1d513a6c4c13aa87ecb606aa5d306eb.zip
ramips: set blocksize for 4MB devices
Set the blocksize for devices having only 4MB of flash for ramips devices already using the new image build code. Informations about the used flash chip are gathered from the OpenWrt wiki, wikidevi, forums, OEM bootlogs or the compatible property in the device tree source file. The en25q32b from the AirLive Air3GII does not have 4k support in the kernel. For the following boards no information about the used flash chip could be found and a 64k blocksize is assumed: - Ralink V11ST-FE - Ralink AP-RT3052-V22RW-2X2 - MediaTek MT7628 EVB - MediaTek MT7621 EVB - UPVEL UR-326N4G - Buffalo WZR-AGL300NH Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 8e742a935d..9ccd3d9833 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -66,6 +66,7 @@ TARGET_DEVICES += ArcherC50
define Device/ex2700
DTS := EX2700
+ BLOCKSIZE := 4k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
IMAGES += factory.bin
KERNEL := $(KERNEL_DTB) | uImage lzma | pad-kernel-ex2700
@@ -76,6 +77,7 @@ TARGET_DEVICES += ex2700
define Device/wt3020-4M
DTS := WT3020-4M
+ BLOCKSIZE := 4k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
IMAGES += factory.bin
IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | poray-header -B WT3020 -F 4M
@@ -394,14 +396,16 @@ TARGET_DEVICES += tiny-ac
define Device/dch-m225
DTS := DCH-M225
+ BLOCKSIZE := 4k
IMAGES += factory.bin
IMAGE_SIZE := 6848k
IMAGE/sysupgrade.bin := \
- append-kernel | pad-offset 65536 64 | append-rootfs | \
+ append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs | \
seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
pad-rootfs | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin := \
- append-kernel | pad-offset 65536 64 | append-rootfs | pad-rootfs -x 64 | \
+ append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
+ append-rootfs | pad-rootfs -x 64 | \
seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
seama-seal -m "signature=wapn22_dlink.2013gui_dap1320b" | \
check-size $$$$(IMAGE_SIZE)