summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorJoseph C. Lehner <joseph.c.lehner@gmail.com>2016-06-01 16:50:03 +0200
committerJohn Crispin <john@phrozen.org>2016-06-05 23:23:57 +0200
commit065de8bd7adf4b8f13f07d5a813e979547b9affe (patch)
tree178ad99fa50e5da52d99072cfb6aac04c633f25c /target/linux/ramips/image/mt7620.mk
parent8b0fbd8e701422baac6455ede312b520cafbc92b (diff)
downloadmaster-31e0f0ae-065de8bd7adf4b8f13f07d5a813e979547b9affe.tar.gz
master-31e0f0ae-065de8bd7adf4b8f13f07d5a813e979547b9affe.tar.bz2
master-31e0f0ae-065de8bd7adf4b8f13f07d5a813e979547b9affe.zip
ramips: fix Netgear EX2700 images
Calling `cat foo bar | dd ... conv=sync` *may* add extraneous padding. Avoid this. Signed-off-by: Joseph C. Lehner <joseph.c.lehner@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index d6da803b52..935f755923 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -8,9 +8,9 @@ define Build/tplink-header
endef
define Build/pad-kernel-ex2700
- dd if=/dev/zero of=$@.pad bs=64 count=1 && cat $@ $@.pad \
- | dd of=$@.new bs=64k conv=sync && truncate -s -64 $@.new \
- && cat ex2700-fakeroot.uImage >> $@.new && rm $@.pad && mv $@.new $@
+ cp $@ $@.tmp && dd if=/dev/zero bs=64 count=1 >> $@.tmp \
+ && dd if=$@.tmp of=$@.new bs=64k conv=sync && truncate -s -64 $@.new \
+ && cat ex2700-fakeroot.uImage >> $@.new && rm $@.tmp && mv $@.new $@
endef
define Build/netgear-header