summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-05-10 14:42:50 +0200
committerJohn Crispin <john@phrozen.org>2016-05-10 14:44:05 +0200
commitf6059cc118709b98ac7865e9487e686f2e8a310c (patch)
tree98be88c7c94c2d1fe17062c72f1e58353d4dcc00 /target/linux/ramips/image/Makefile
parentfda951c4437fe46db00da2e0aa80dfe4972e3a27 (diff)
downloadmaster-31e0f0ae-f6059cc118709b98ac7865e9487e686f2e8a310c.tar.gz
master-31e0f0ae-f6059cc118709b98ac7865e9487e686f2e8a310c.tar.bz2
master-31e0f0ae-f6059cc118709b98ac7865e9487e686f2e8a310c.zip
ramips: fix DTB generation
using preprocessor style includes when calling dtc directly. Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 6e0349f021..52dde6780e 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -107,7 +107,7 @@ endef
# $(3), optional filename suffix, e.g. "-initramfs"
define PatchKernelLzmaDtb
cp $(KDIR)/vmlinux$(3) $(KDIR)/vmlinux-$(1)$(3)
- $(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $(KDIR)/$(2).dtb ../dts/$(2).dts
+ $(call Image/BuildDTB,../dts/$(2).dts,$(KDIR)/$(2).dtb)
$(STAGING_DIR_HOST)/bin/patch-dtb $(KDIR)/vmlinux-$(1)$(3) $(KDIR)/$(2).dtb
$(call CompressLzma,$(KDIR)/vmlinux-$(1)$(3),$(KDIR)/vmlinux-$(1)$(3).bin.lzma)
endef