summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-06 09:31:31 +0000
committerJohn Crispin <john@openwrt.org>2014-11-06 09:31:31 +0000
commitcadf5171074f7b18d007470b9f89deea87bb4c46 (patch)
tree2a4982693fd872563f0aabe73941c705e2cc21ed /target/linux/ramips/image/Makefile
parentf8404aaf9e44bab6fb629d5ee106e50ca2943d1c (diff)
downloadmaster-31e0f0ae-cadf5171074f7b18d007470b9f89deea87bb4c46.tar.gz
master-31e0f0ae-cadf5171074f7b18d007470b9f89deea87bb4c46.tar.bz2
master-31e0f0ae-cadf5171074f7b18d007470b9f89deea87bb4c46.zip
ralink: add support for mt7628
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 43197
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 58bfd6dfe4..4362d4c3b3 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -848,6 +848,18 @@ define Image/Build/Profile/Default
endef
endif
+#
+# MT7628 Profiles
+#
+
+Image/Build/Profile/MT7628=$(call BuildFirmware/Default4M/$(1),$(1),mt7628,MT7628)
+
+ifeq ($(SUBTARGET),mt7628)
+define Image/Build/Profile/Default
+ $(call Image/Build/Profile/MT7628,$(1))
+endef
+endif
+
#
# Generic Targets