summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-12-13 10:53:34 +0000
committerJohn Crispin <john@openwrt.org>2013-12-13 10:53:34 +0000
commitb4b0a55aabd2839c5c995bb226f528efca73eea5 (patch)
tree5590872e7727102a707ee126637130489a674f12 /target/linux/ramips/image/Makefile
parent594442a37e40f7839b144036e1e2ade8a1d58f86 (diff)
downloadmaster-31e0f0ae-b4b0a55aabd2839c5c995bb226f528efca73eea5.tar.gz
master-31e0f0ae-b4b0a55aabd2839c5c995bb226f528efca73eea5.tar.bz2
master-31e0f0ae-b4b0a55aabd2839c5c995bb226f528efca73eea5.zip
ralink: add mt7621 support
there are still various missing pieces for full support. Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 39040
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 32047ccfed..82addb27f8 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -29,10 +29,16 @@ define kernel_entry
-a 0x88000000 -e 0x88000000
endef
else
+ifeq ($(CONFIG_SOC_MT7621),y)
+define kernel_entry
+-a 0x80001000 -e 0x80001000
+endef
+else
define kernel_entry
-a 0x80000000 -e 0x80000000
endef
endif
+endif
define MkCombineduImage
$(call PatchKernelLzma,$(2),$(3))
@@ -649,6 +655,19 @@ endif
#
+# MT7621 Profiles
+#
+
+Image/Build/Profile/MT7621=$(call BuildFirmware/Default4M/$(1),$(1),mt7621,MT7621)
+
+ifeq ($(SUBTARGET),mt7621)
+define Image/Build/Profile/Default
+ $(call Image/Build/Profile/MT7621,$(1))
+endef
+endif
+
+
+#
# Generic Targets
#
define Image/BuildKernel