summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-06 18:39:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-06 18:39:13 +0000
commit471a567a884595241034a6939b28d74ad3dba4d4 (patch)
treedb31a36d7f560d091eaa61f8912f999f4f434185 /target/linux/ramips/image/Makefile
parent2499a57d92409e767386d0d36684952c20735656 (diff)
downloadmaster-31e0f0ae-471a567a884595241034a6939b28d74ad3dba4d4.tar.gz
master-31e0f0ae-471a567a884595241034a6939b28d74ad3dba4d4.tar.bz2
master-31e0f0ae-471a567a884595241034a6939b28d74ad3dba4d4.zip
ramips: do not rely on $(BIN_DIR) installed files during image build (for ubnt-erx)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48147
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 05d979573a..2427ac6d0f 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -77,10 +77,10 @@ define Build/ubnt-erx-factory-compat
endef
define Build/ubnt-erx-factory-kernel
- if [ -e $(BIN_DIR)/$(KERNEL_INITRAMFS_IMAGE) ]; then \
- $(TAR) -rf $@ --transform='s/^.*/vmlinux.tmp/' $(BIN_DIR)/$(KERNEL_INITRAMFS_IMAGE); \
+ if [ -e $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) ]; then \
+ $(TAR) -rf $@ --transform='s/^.*/vmlinux.tmp/' $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE); \
\
- md5sum --binary $(BIN_DIR)/$(KERNEL_INITRAMFS_IMAGE) | awk '{print $$1}'> $@.md5; \
+ md5sum --binary $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) | awk '{print $$1}'> $@.md5; \
$(TAR) -rf $@ --transform='s/^.*/vmlinux.tmp.md5/' $@.md5; \
$(RM) $@.md5; \
fi