summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-17 21:20:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-17 21:20:05 +0000
commit40b740b23234574115225bf8bde7bc679f8034e1 (patch)
tree18b31dc33af7cf8723faefd73e0672b2f0fb987d /target/linux/ramips/image/Makefile
parent4d4536b090797c7d8918b8c24ca246aff1fcd942 (diff)
downloadmaster-31e0f0ae-40b740b23234574115225bf8bde7bc679f8034e1.tar.gz
master-31e0f0ae-40b740b23234574115225bf8bde7bc679f8034e1.tar.bz2
master-31e0f0ae-40b740b23234574115225bf8bde7bc679f8034e1.zip
ramips: add preliminary support for DIR-860L B1
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44016
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile43
1 files changed, 42 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 5e4cea35ac..f935a95d3b 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -51,6 +51,24 @@ define Build/trx
-a 4 -f $(word 2,$^)
endef
+define Build/seama
+ $(STAGING_DIR_HOST)/bin/seama -i $@ $(1)
+ mv $@.seama $@
+endef
+
+define Build/seama-seal
+ $(call Build/seama,-s $@.seama $(1))
+endef
+
+define Build/relocate-kernel
+ ( \
+ dd if=$(KDIR)/relocate/loader.bin bs=32 conv=sync && \
+ perl -e '@s = stat("$@"); print pack("V", @s[7])' && \
+ cat $@ \
+ ) > $@.new
+ mv $@.new $@
+endef
+
define MkCombineduImage
$(call PatchKernelLzma,$(2),$(3))
if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt `expr $(4) - 64` ]; then \
@@ -875,7 +893,7 @@ endif
#
ifeq ($(SUBTARGET),mt7621)
- TARGET_DEVICES += mt7621 wsr-600 wsr-1166
+ TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1
endif
define Device/mt7621
@@ -892,6 +910,21 @@ define Device/wsr-1166
IMAGE/sysupgrade.bin := trx | pad-rootfs
endef
+define Device/dir-860l-b1
+ DTS := DIR-860L-B1
+ IMAGES += factory.bin
+ KERNEL := kernel-bin | patch-dtb | relocate-kernel | lzma | uImage lzma
+ IMAGE/sysupgrade.bin := \
+ append-kernel | pad-offset 65536 64 | append-rootfs | \
+ seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
+ pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := \
+ append-kernel | pad-offset 65536 64 | append-rootfs | pad-rootfs -x 64 | \
+ seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
+ check-size $$$$(IMAGE_SIZE) | \
+ seama-seal -m "signature=wrgac13_dlink.2013gui_dir860lb"
+endef
+
#
# MT7628 Profiles
#
@@ -932,4 +965,12 @@ define Image/Build
endef
endif
+ifeq ($(SUBTARGET),mt7621)
+define Build/Compile
+ rm -rf $(KDIR)/relocate
+ $(CP) ./relocate $(KDIR)
+ $(MAKE) -C $(KDIR)/relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
+endef
+endif
+
$(eval $(call BuildImage))