summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-16 21:19:18 +0000
committerJohn Crispin <john@openwrt.org>2015-02-16 21:19:18 +0000
commit361839151407c897bb1856bc66712a28dc7f0024 (patch)
tree284caad2ce76c6a7a53fdc095b000b4784c59174 /target/linux/ramips/image/Makefile
parentf440414c55f770e02e3b6a4b827b7b3820fd9101 (diff)
downloadmaster-31e0f0ae-361839151407c897bb1856bc66712a28dc7f0024.tar.gz
master-31e0f0ae-361839151407c897bb1856bc66712a28dc7f0024.tar.bz2
master-31e0f0ae-361839151407c897bb1856bc66712a28dc7f0024.zip
ramips: Buffalo WZR-AGL300NH target support
I got work with this patch. Ethernet switch (includes VLAN), WiFi connected via PCIe, LEDs, buttons. In mtd partion map of DTS file, I renamed Linux firmware regions (kernel + root squashfs) to “firmware”because it allows kernel to split kernel and roots and rootfsdata. signed-off-by: ngc@ff.iij4u.or.jp —— —— SVN-Revision: 44470
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 73637300fd..6e6b10bd46 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -395,6 +395,8 @@ Image/Build/Profile/V11STFE=$(call BuildFirmware/Default4M/$(1),$(1),v11st-fe,V1
Image/Build/Profile/WLITX4AG300N=$(call BuildFirmware/Default4M/$(1),$(1),wli-tx4-ag300n,WLI-TX4-AG300N)
+Image/Build/Profile/WZRAGL300NH=$(call BuildFirmware/Default4M/$(1),$(1),wzr-agl300nh,WZR-AGL300NH)
+
ifeq ($(SUBTARGET),rt288x)
define Image/Build/Profile/Default
$(call Image/Build/Profile/AR670W,$(1))
@@ -403,6 +405,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/RTN15,$(1))
$(call Image/Build/Profile/V11STFE,$(1))
$(call Image/Build/Profile/WLITX4AG300N,$(1))
+ $(call Image/Build/Profile/WZRAGL300NH,$(1))
endef
endif