summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-04-21 12:30:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-04-21 12:30:40 +0000
commitfc88a363c07ac47cefbf3ea3b08c49ab448d2747 (patch)
tree71af98376ec10ae864ddcdb27dd17711c0c7dda9 /target/linux/ramips/files
parent88b5827c52b811066d48dbdc9fe4f021295d1d16 (diff)
downloadmaster-31e0f0ae-fc88a363c07ac47cefbf3ea3b08c49ab448d2747.tar.gz
master-31e0f0ae-fc88a363c07ac47cefbf3ea3b08c49ab448d2747.tar.bz2
master-31e0f0ae-fc88a363c07ac47cefbf3ea3b08c49ab448d2747.zip
ramips: rt305x: add initial support for Tenda W306R V2.0
More device info at: http://wiki.openwrt.org/toh/tenda/w306r Signed-off-by: David Pearce <David_18051985@hotmail.com.au> [juhosg: fix checkpatch errors, remove kmod-phy and luci-ssl packages from the profile, change broken GPIO number] SVN-Revision: 31396
Diffstat (limited to 'target/linux/ramips/files')
-rw-r--r--target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig5
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c72
4 files changed, 79 insertions, 0 deletions
diff --git a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
index c2ec146c97..08b04f9af4 100644
--- a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
+++ b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
@@ -45,6 +45,7 @@ enum ramips_mach_type {
RAMIPS_MACH_PWH2004, /* Prolink 2004H / Abocom 5205 */
RAMIPS_MACH_SL_R7205, /* Skylink SL-R7205 Wireless 3G Router*/
RAMIPS_MACH_V22RW_2X2, /* Ralink AP-RT3052-V22RW-2X2 */
+ RAMIPS_MACH_W306R_V20, /* Tenda W306R_V20 */
RAMIPS_MACH_W502U, /* ALFA Networks W502U */
RAMIPS_MACH_WCR150GN, /* Sparklan WCR-150GN */
RAMIPS_MACH_WHR_G300N, /* Buffalo WHR-G300N */
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
index ef4ddf4097..b9850a651f 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
@@ -104,6 +104,11 @@ config RT305X_MACH_V22RW_2X2
select RALINK_DEV_GPIO_BUTTONS
select RALINK_DEV_GPIO_LEDS
+config RT305X_MACH_W306R_V20
+ bool "Tenda W306R V2.0 board support"
+ select RALINK_DEV_GPIO_BUTTONS
+ select RALINK_DEV_GPIO_LEDS
+
config RT305X_MACH_WL341V3
bool "Sitecom WL-341 v3 board support"
select RALINK_DEV_GPIO_BUTTONS
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
index 0336936505..f5c6aa8dfe 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
@@ -29,6 +29,7 @@ obj-$(CONFIG_RT305X_MACH_RT_G32_REVB) += mach-rt-g32-revb.o
obj-$(CONFIG_RT305X_MACH_RT_N10_PLUS) += mach-rt-n10-plus.o
obj-$(CONFIG_RT305X_MACH_SL_R7205) += mach-sl-r7205.o
obj-$(CONFIG_RT305X_MACH_V22RW_2X2) += mach-v22rw-2x2.o
+obj-$(CONFIG_RT305X_MACH_W306R_V20) += mach-w306r-v20.o
obj-$(CONFIG_RT305X_MACH_W502U) += mach-w502u.o
obj-$(CONFIG_RT305X_MACH_WCR150GN) += mach-wcr150gn.o
obj-$(CONFIG_RT305X_MACH_WHR_G300N) += mach-whr-g300n.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c
new file mode 100644
index 0000000000..6235a7329d
--- /dev/null
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c
@@ -0,0 +1,72 @@
+/*
+ * Tenda W306R V2.0 board support
+ *
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/ethtool.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+#include <asm/mach-ralink/ramips_eth_platform.h>
+
+#include "devices.h"
+
+#define W306R_V20_GPIO_LED_SYS 9 /* FIXME */
+#define W306R_V20_GPIO_LED_WPS 13
+
+#define W306R_V20_GPIO_BUTTON_RESET 10
+
+#define W306R_V20_KEYS_POLL_INTERVAL 20
+#define W306R_V20_KEYS_DEBOUNCE_INTERVAL (3 * W306R_V20_KEYS_POLL_INTERVAL)
+
+static struct gpio_led w306r_v20_leds_gpio[] __initdata = {
+ {
+ .name = "w306r-v20:green:sys",
+ .gpio = W306R_V20_GPIO_LED_SYS,
+ .active_low = 1,
+ }, {
+ .name = "w306r-v20:green:wps",
+ .gpio = W306R_V20_GPIO_LED_WPS,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_keys_button w306r_v20_gpio_buttons[] __initdata = {
+ {
+ .desc = "RESET/WPS",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = W306R_V20_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = W306R_V20_GPIO_BUTTON_RESET,
+ .active_low = 1,
+ }
+};
+
+static void __init w306r_v20_init(void)
+{
+ rt305x_register_flash(0);
+
+ rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+
+ rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_LLLLW;
+ rt305x_register_ethernet();
+ ramips_register_gpio_leds(-1, ARRAY_SIZE(w306r_v20_leds_gpio),
+ w306r_v20_leds_gpio);
+ ramips_register_gpio_buttons(-1, W306R_V20_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(w306r_v20_gpio_buttons),
+ w306r_v20_gpio_buttons);
+ rt305x_register_wifi();
+ rt305x_register_wdt();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_W306R_V20, "W306R_V20", "Tenda W306R V2.0",
+ w306r_v20_init);