summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files/arch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-06-19 09:52:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-06-19 09:52:15 +0000
commit833b4af81602e0afc302060972038dfbbc993708 (patch)
treebbb31daf1c76fa49712b20bbebac879681244d60 /target/linux/ramips/files/arch
parent431e612d9e885471a4cf28288b1673d290e0c782 (diff)
downloadmaster-31e0f0ae-833b4af81602e0afc302060972038dfbbc993708.tar.gz
master-31e0f0ae-833b4af81602e0afc302060972038dfbbc993708.tar.bz2
master-31e0f0ae-833b4af81602e0afc302060972038dfbbc993708.zip
ramips: rt305x: add support for the Petatel PSR-680W Wireless CDMA Router
This patch adds support for the Korean made Petatel PSR-680W Wireless CDMA Router. The platform is based on Ralink RT3052. http://wiki.openwrt.org/toh/petatel/psr-680w Signed-off-by: Dmitry Shmygov <shmygov at rambler.ru> SVN-Revision: 32450
Diffstat (limited to 'target/linux/ramips/files/arch')
-rw-r--r--target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig5
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/mach-psr-680w.c73
4 files changed, 80 insertions, 0 deletions
diff --git a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
index 8498680521..d0476f59ba 100644
--- a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
+++ b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
@@ -43,6 +43,7 @@ enum ramips_mach_type {
RAMIPS_MACH_MOFI3500_3GN, /* MoFi Network MOFI3500-3GN */
RAMIPS_MACH_NBG_419N, /* ZyXEL NBG-419N */
RAMIPS_MACH_OMNI_EMB, /* Omnima MiniEMBWiFi */
+ RAMIPS_MACH_PSR_680W, /* Petatel PSR-680W Wireless 3G Router*/
RAMIPS_MACH_PWH2004, /* Prolink 2004H / Abocom 5205 */
RAMIPS_MACH_SL_R7205, /* Skylink SL-R7205 Wireless 3G Router*/
RAMIPS_MACH_V22RW_2X2, /* Ralink AP-RT3052-V22RW-2X2 */
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
index f2a7d84870..15d3a4c291 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
@@ -104,6 +104,11 @@ config RT305X_MACH_OMNI_EMB
select RALINK_DEV_GPIO_BUTTONS
select RALINK_DEV_GPIO_LEDS
+config RT305X_MACH_PSR_680W
+ bool "Petatel PSR-680W Wireless 3G Router support"
+ select RALINK_DEV_GPIO_BUTTONS
+ select RALINK_DEV_GPIO_LEDS
+
config RT305X_MACH_PWH2004
bool "Prolink PWH2004 / Abocom WR5205 support (32M RAM, 8M flash)"
select RALINK_DEV_GPIO_BUTTONS
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
index 9cbd04dda9..9fe1991fc3 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
@@ -24,6 +24,7 @@ obj-$(CONFIG_RT305X_MACH_MOFI3500_3GN) += mach-mofi3500-3gn.o
obj-$(CONFIG_RT305X_MACH_NBG_419N) += mach-nbg-419n.o
obj-$(CONFIG_RT305X_MACH_NW718) += mach-nw718.o
obj-$(CONFIG_RT305X_MACH_OMNI_EMB) += mach-omni-emb.o
+obj-$(CONFIG_RT305X_MACH_PSR_680W) += mach-psr-680w.o
obj-$(CONFIG_RT305X_MACH_PWH2004) += mach-pwh2004.o
obj-$(CONFIG_RT305X_MACH_RT_G32_REVB) += mach-rt-g32-revb.o
obj-$(CONFIG_RT305X_MACH_RT_N10_PLUS) += mach-rt-n10-plus.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-psr-680w.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-psr-680w.c
new file mode 100644
index 0000000000..a6d10f7cbe
--- /dev/null
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-psr-680w.c
@@ -0,0 +1,73 @@
+/*
+ * Petatel PSR-680W Wireless 3G Router support
+ *
+ * Copyright (C) 2012 Dmitry Shmygov <shmygov@rambler.ru>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define PSR_680W_GPIO_BUTTON_RESET 0 /* active low */
+
+#define PSR_680W_GPIO_LED_STATUS 19
+
+#define PSR_680W_KEYS_POLL_INTERVAL 20
+#define PSR_680W_KEYS_DEBOUNCE_INTERVAL (3 * PSR_680W_KEYS_POLL_INTERVAL)
+
+
+static struct gpio_led psr_680w_leds_gpio[] __initdata = {
+ {
+ .name = "psr-680w:red:wan",
+ .gpio = PSR_680W_GPIO_LED_STATUS,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_keys_button psr_680w_gpio_buttons[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = PSR_680W_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = PSR_680W_GPIO_BUTTON_RESET,
+ .active_low = 1,
+ }
+};
+
+static void __init psr_680w_init(void)
+{
+ rt305x_gpio_init((RT305X_GPIO_MODE_I2S_UARTF << RT305X_GPIO_MODE_UART0_SHIFT) |
+ RT305X_GPIO_MODE_SPI |
+ RT305X_GPIO_MODE_JTAG |
+ RT305X_GPIO_MODE_MDIO |
+ RT305X_GPIO_MODE_RGMII);
+
+ rt305x_register_flash(0);
+
+ rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_WLLLL;
+ rt305x_register_ethernet();
+ ramips_register_gpio_leds(-1, ARRAY_SIZE(psr_680w_leds_gpio),
+ psr_680w_leds_gpio);
+ ramips_register_gpio_buttons(-1, PSR_680W_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(psr_680w_gpio_buttons),
+ psr_680w_gpio_buttons);
+ rt305x_register_wifi();
+ rt305x_register_wdt();
+ rt305x_register_usb();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_PSR_680W, "PSR-680W",
+ "Petatel PSR-680W Wireless 3G Router",
+ psr_680w_init);