summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/dts/MIWIFI-NANO.dts
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-16 09:26:48 +0000
committerJohn Crispin <john@openwrt.org>2016-03-16 09:26:48 +0000
commit99414dbcf1901a8f362e62febe562dacd4595c8e (patch)
tree1927d20fe846d8453e5501087f3a6643b7d438aa /target/linux/ramips/dts/MIWIFI-NANO.dts
parent553c1b793f6de84e8ed545535f1ee54c4c4c0581 (diff)
downloadmaster-31e0f0ae-99414dbcf1901a8f362e62febe562dacd4595c8e.tar.gz
master-31e0f0ae-99414dbcf1901a8f362e62febe562dacd4595c8e.tar.bz2
master-31e0f0ae-99414dbcf1901a8f362e62febe562dacd4595c8e.zip
ramips: Add support for Xiaomi MiWiFi Nano
Xiaomi MiWiFi Nano is based on Mediatek MT7628 with 64MB ram 16MB flash Signed-off-by: Noble Pepper <openwrtmail@noblepepper.com> v3 includes changes suggested by L. D. Pinney & Karl Palsson- Eliminate en25q64 (4MB) flash chip Alphabetization Remove hyphen in model Rename profile from miwifinano.mk to xiaomi.mk Add gpios that are attached to leds SVN-Revision: 49024
Diffstat (limited to 'target/linux/ramips/dts/MIWIFI-NANO.dts')
-rw-r--r--target/linux/ramips/dts/MIWIFI-NANO.dts99
1 files changed, 99 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/MIWIFI-NANO.dts b/target/linux/ramips/dts/MIWIFI-NANO.dts
new file mode 100644
index 0000000000..ea7b27035a
--- /dev/null
+++ b/target/linux/ramips/dts/MIWIFI-NANO.dts
@@ -0,0 +1,99 @@
+/dts-v1/;
+
+/include/ "mt7628an.dtsi"
+
+/ {
+ compatible = "xiaomi,MiWifi Nano", "mediatek,mt7628an-soc";
+ model = "MiWiFi Nano";
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ memory@0 {
+ device_type = "memory";
+ reg = <0x0 0x4000000>;
+ };
+
+ pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "gpio";
+ ralink,function = "gpio";
+ };
+ };
+ };
+
+ gpio-export {
+ compatible = "gpio-export";
+ #size-cells = <0>;
+
+ gpio11 {
+ /* blue led */
+ gpio-export,name = "gpio11";
+ gpio-export,direction_may_change = <1>;
+ gpio-export,output = <1>;
+ gpios = <&gpio0 11 0>;
+ };
+
+ gpio37 {
+ /* red led */
+ gpio-export,name = "gpio37";
+ gpio-export,direction_may_change = <1>;
+ gpio-export,output = <1>;
+ gpios = <&gpio1 5 0>;
+ };
+
+ gpio44 {
+ /* yellow led */
+ gpio-export,name = "gpio44";
+ gpio-export,direction_may_change = <1>;
+ gpio-export,output = <1>;
+ gpios = <&gpio1 12 0>;
+ };
+ };
+
+
+ wmac@10300000 {
+ status = "okay";
+ };
+
+ palmbus@10000000 {
+ spi@b00 {
+ status = "okay";
+
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0 0>;
+ linux,modalias = "m25p80";
+ spi-max-frequency = <10000000>;
+ m25p,chunked-io = <32>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+ };
+ };
+ };
+};