summaryrefslogtreecommitdiffstats
path: root/target/linux/pxa/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-10-03 16:15:05 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-10-03 16:15:05 +0000
commit47c5c4df1c13f9118b81b6de55a9d695024e0fb9 (patch)
tree88412f5c4f1eb6fc2e47dbb1661fc95c23de969b /target/linux/pxa/image
parent89a9742bf7943fd733a35bed1995929cb9993452 (diff)
downloadmaster-31e0f0ae-47c5c4df1c13f9118b81b6de55a9d695024e0fb9.tar.gz
master-31e0f0ae-47c5c4df1c13f9118b81b6de55a9d695024e0fb9.tar.bz2
master-31e0f0ae-47c5c4df1c13f9118b81b6de55a9d695024e0fb9.zip
add Default and Gumstix PXA profiles
Gumstix builds a fake flash image for usage in qemu SVN-Revision: 33609
Diffstat (limited to 'target/linux/pxa/image')
-rw-r--r--target/linux/pxa/image/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/target/linux/pxa/image/Makefile b/target/linux/pxa/image/Makefile
index 74edb62be0..7f2b5d4123 100644
--- a/target/linux/pxa/image/Makefile
+++ b/target/linux/pxa/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -15,8 +15,20 @@ define Image/BuildKernel
cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
endef
+# Build a fake flash image for usage in Qemu
+define Image/Build/Gumstix
+ dd if=/dev/zero bs=128k count=256 of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+ dd if=$(BIN_DIR)/openwrt-pxa-gumstix-u-boot.bin conv=notrunc bs=128k \
+ of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+ dd if=$(KDIR)/root.$(1) conv=notrunc bs=128k seek=2 \
+ of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+ dd if=$(KDIR)/uImage conv=notrunc bs=128k seek=248 \
+ of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+endef
+
define Image/Build
$(call Image/Build/$(1),$(1))
+ $(call Image/Build/$(PROFILE),$(1))
endef
define Image/Build/jffs2-64k