summaryrefslogtreecommitdiffstats
path: root/target/linux/ps3/petitboot/profiles/000-Default.mk
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2009-04-16 10:40:15 +0000
committerHamish Guthrie <hcg@openwrt.org>2009-04-16 10:40:15 +0000
commitffc86f7e3a5b4be7dfdee2f201cfa4fc2a30a40e (patch)
tree6c6b1de678ad45d1fe93a8126174855f236b895c /target/linux/ps3/petitboot/profiles/000-Default.mk
parenta2457665070d609a457d68c1eeb051b12bf43531 (diff)
downloadmaster-31e0f0ae-ffc86f7e3a5b4be7dfdee2f201cfa4fc2a30a40e.tar.gz
master-31e0f0ae-ffc86f7e3a5b4be7dfdee2f201cfa4fc2a30a40e.tar.bz2
master-31e0f0ae-ffc86f7e3a5b4be7dfdee2f201cfa4fc2a30a40e.zip
Update default configuration to use profiles
SVN-Revision: 15229
Diffstat (limited to 'target/linux/ps3/petitboot/profiles/000-Default.mk')
-rw-r--r--target/linux/ps3/petitboot/profiles/000-Default.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ps3/petitboot/profiles/000-Default.mk b/target/linux/ps3/petitboot/profiles/000-Default.mk
new file mode 100644
index 0000000000..5c433e1339
--- /dev/null
+++ b/target/linux/ps3/petitboot/profiles/000-Default.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default PS3 Petitboot profile
+ PACKAGES:=-dnsmasq -iptables -ppp -ppp-mod-pppoe -kmod-ipt-nathelper \
+ -firewall \
+ kexec-tools petitboot
+endef
+
+define Profile/Default/Description
+ Default PS3 Petitboot profile
+endef
+$(eval $(call Profile,Default))
+