summaryrefslogtreecommitdiffstats
path: root/target/linux/ps3/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-10-23 06:23:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-10-23 06:23:41 +0000
commita2af03953b4cf460f6c49845a53fb384820095f6 (patch)
tree870dc875c6b01a55e5c2b1ad2a373cda166182c4 /target/linux/ps3/image/Makefile
parenta10edd4cee0f1a6d3fe8af2bb8f3873c1cbcbe21 (diff)
downloadmaster-31e0f0ae-a2af03953b4cf460f6c49845a53fb384820095f6.tar.gz
master-31e0f0ae-a2af03953b4cf460f6c49845a53fb384820095f6.tar.bz2
master-31e0f0ae-a2af03953b4cf460f6c49845a53fb384820095f6.zip
Add ps3 target
This patch adds a target for the Sony PlayStation 3. Signed-off-by: Jeremy Kerr <jk@ozlabs.org> SVN-Revision: 9413
Diffstat (limited to 'target/linux/ps3/image/Makefile')
-rw-r--r--target/linux/ps3/image/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ps3/image/Makefile b/target/linux/ps3/image/Makefile
new file mode 100644
index 0000000000..e5de26558e
--- /dev/null
+++ b/target/linux/ps3/image/Makefile
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/powerpc/boot/otheros.bld $(KDIR)/image
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/image $(BIN_DIR)/otheros-$(BOARD)-$(KERNEL).bld
+endef
+
+$(eval $(call BuildImage))