summaryrefslogtreecommitdiffstats
path: root/target/linux/ppc44x/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-01-27 23:11:21 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-01-27 23:11:21 +0000
commitf66f06c1894b7becb24cad683f10201e04d60724 (patch)
treeb57575ff6308e27f44770db90ced803a253505f9 /target/linux/ppc44x/image
parent759ccc4b8b3fd9ec9ad34423e5ee53131de77c55 (diff)
downloadmaster-31e0f0ae-f66f06c1894b7becb24cad683f10201e04d60724.tar.gz
master-31e0f0ae-f66f06c1894b7becb24cad683f10201e04d60724.tar.bz2
master-31e0f0ae-f66f06c1894b7becb24cad683f10201e04d60724.zip
* Rename the AMCC target to PPC44x * Upgrade PPC44x to 2.6.23
SVN-Revision: 10290
Diffstat (limited to 'target/linux/ppc44x/image')
-rw-r--r--target/linux/ppc44x/image/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ppc44x/image/Makefile b/target/linux/ppc44x/image/Makefile
new file mode 100644
index 0000000000..bd284eb975
--- /dev/null
+++ b/target/linux/ppc44x/image/Makefile
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+JFFS2_BLOCKSIZE=256k
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/ppc/boot/images/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-256k
+ ( \
+ dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=4096k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-jffs2.img
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ ( \
+ dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=4096k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
+endef
+
+$(eval $(call BuildImage))