summaryrefslogtreecommitdiffstats
path: root/target/linux/ppc44x/image
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
commite2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f (patch)
treef8563604e7685c30b0a2a675ca80379a34114565 /target/linux/ppc44x/image
parent040c06438896144dfe148910f922a0d9bb0058b0 (diff)
downloadmaster-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.gz
master-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.bz2
master-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.zip
define a shared IMG_PREFIX variable used as a basename for image files, it contains board & subtarget infos (if appropriate) allowing subtargets to share the same bin directory without overwriting each other's files
SVN-Revision: 20834
Diffstat (limited to 'target/linux/ppc44x/image')
-rw-r--r--target/linux/ppc44x/image/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ppc44x/image/Makefile b/target/linux/ppc44x/image/Makefile
index aa6851341a..af4b26c537 100644
--- a/target/linux/ppc44x/image/Makefile
+++ b/target/linux/ppc44x/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -15,7 +15,7 @@ define Image/Prepare
endef
define Image/BuildKernel
- cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+ cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
endef
define Image/Build
@@ -26,7 +26,7 @@ define Image/Build/jffs2-256k
( \
dd if=$(KDIR)/uImage bs=2048k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-jffs2.img
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-jffs2.img
endef
define Image/Build/squashfs
@@ -34,12 +34,12 @@ define Image/Build/squashfs
( \
dd if=$(KDIR)/uImage bs=2048k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-taishan-$(1).img
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-taishan-$(1).img
( \
dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
dd if=$(KDIR)/openwrt-canyonlands.dtb bs=128k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-canyonlands-$(1).img
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-canyonlands-$(1).img
endef
$(eval $(call BuildImage))