summaryrefslogtreecommitdiffstats
path: root/target/linux/ppc44x/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-02-03 14:54:01 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-02-03 14:54:01 +0000
commit98236f47c8bf854c4350765de24df6392bf25cfb (patch)
tree5e092cc71b419ef4f41dc4222046d1478eed6ba1 /target/linux/ppc44x/image
parent4f71fabba4e42becf7f5a072cce3df3190961600 (diff)
downloadmaster-31e0f0ae-98236f47c8bf854c4350765de24df6392bf25cfb.tar.gz
master-31e0f0ae-98236f47c8bf854c4350765de24df6392bf25cfb.tar.bz2
master-31e0f0ae-98236f47c8bf854c4350765de24df6392bf25cfb.zip
convert ppc44x to arch/powerpc, use squashfs images by default
SVN-Revision: 10372
Diffstat (limited to 'target/linux/ppc44x/image')
-rw-r--r--target/linux/ppc44x/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ppc44x/image/Makefile b/target/linux/ppc44x/image/Makefile
index bd284eb975..5c1d023cb0 100644
--- a/target/linux/ppc44x/image/Makefile
+++ b/target/linux/ppc44x/image/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE=256k
define Image/Prepare
- cp $(LINUX_DIR)/arch/ppc/boot/images/uImage $(KDIR)/uImage
+ cp $(LINUX_DIR)/arch/powerpc/boot/cuImage.taishan $(KDIR)/uImage
endef
define Image/BuildKernel
@@ -23,7 +23,7 @@ endef
define Image/Build/jffs2-256k
( \
- dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=4096k conv=sync; \
+ dd if=$(KDIR)/uImage bs=2048k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-jffs2.img
endef
@@ -31,7 +31,7 @@ endef
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
( \
- dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=4096k conv=sync; \
+ dd if=$(KDIR)/uImage bs=2048k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
endef