summaryrefslogtreecommitdiffstats
path: root/target/linux/ppc44x/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-01-30 11:38:46 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-01-30 11:38:46 +0000
commit8bf0df99771f6088867cebd7e4eed61dfb387454 (patch)
tree515920e6e540dc950f0e1a065239143d216ccf4f /target/linux/ppc44x/image
parent3a4b459fbf96833ce5afcdfec630b290c1e9b9da (diff)
downloadmaster-31e0f0ae-8bf0df99771f6088867cebd7e4eed61dfb387454.tar.gz
master-31e0f0ae-8bf0df99771f6088867cebd7e4eed61dfb387454.tar.bz2
master-31e0f0ae-8bf0df99771f6088867cebd7e4eed61dfb387454.zip
upgrade ppc44x to 2.6.28.2, add basic support for the AMCC Canyonlands
SVN-Revision: 14280
Diffstat (limited to 'target/linux/ppc44x/image')
-rw-r--r--target/linux/ppc44x/image/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/target/linux/ppc44x/image/Makefile b/target/linux/ppc44x/image/Makefile
index 5c1d023cb0..b8d5e95109 100644
--- a/target/linux/ppc44x/image/Makefile
+++ b/target/linux/ppc44x/image/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -11,6 +11,7 @@ JFFS2_BLOCKSIZE=256k
define Image/Prepare
cp $(LINUX_DIR)/arch/powerpc/boot/cuImage.taishan $(KDIR)/uImage
+ dtc -O dtb -R 4 -S 0x20000 $(LINUX_DIR)/arch/powerpc/boot/dts/canyonlands.dts > $(KDIR)/openwrt-canyonlands.dtb
endef
define Image/BuildKernel
@@ -33,7 +34,12 @@ define Image/Build/squashfs
( \
dd if=$(KDIR)/uImage bs=2048k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-taishan-$(1).img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
+ dd if=$(KDIR)/openwrt-canyonlands.dtb bs=128k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-canyonlands-$(1).img
endef
$(eval $(call BuildImage))