summaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-19 06:42:30 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-19 06:42:30 +0000
commiteec23618ad2acede20c835f962b682acc1f13de9 (patch)
tree3dc1d404baa89b3720044f9bfaa79160dbe6a117 /target/linux/ppc40x/image
parent7e2c1008ff7e784d8fb2c970f02fb569f4d7caac (diff)
downloadmaster-31e0f0ae-eec23618ad2acede20c835f962b682acc1f13de9.tar.gz
master-31e0f0ae-eec23618ad2acede20c835f962b682acc1f13de9.tar.bz2
master-31e0f0ae-eec23618ad2acede20c835f962b682acc1f13de9.zip
increase linux partition size, and fix jffs2 images
SVN-Revision: 16906
Diffstat (limited to 'target/linux/ppc40x/image')
-rw-r--r--target/linux/ppc40x/image/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
index b54cc06488..a5be9be92a 100644
--- a/target/linux/ppc40x/image/Makefile
+++ b/target/linux/ppc40x/image/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-JFFS2_BLOCKSIZE=128k
+JFFS2_BLOCKSIZE=128k 64k
define Image/Prepare
cp $(LINUX_DIR)/arch/powerpc/boot/uImage $(KDIR)/uImage
@@ -28,13 +28,16 @@ define Image/Build/jffs2-128k
dd if=$(KDIR)/openwrt-kilauea.dtb bs=128k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-kilauea-jffs2.img
+endef
+
+define Image/Build/jffs2-64k
( \
- dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv1 bs=1024k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv1 bs=1152k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv1-jffs2.img
( \
- dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1024k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1152k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv2-jffs2.img
endef
@@ -46,11 +49,11 @@ define Image/Build/squashfs
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-kilauea-$(1).img
( \
- dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv1 bs=1024k conv=sync; \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv1 bs=1152k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv1-$(1).img
( \
- dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1024k conv=sync; \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1152k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv2-$(1).img
endef