summaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-19 07:38:06 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-19 07:38:06 +0000
commitc84a5161c5e4c5ea71715f60b937d8cf45592fde (patch)
tree43756b238e92cc94eae02278a8f36ab352099ac9 /target/linux/ppc40x/image
parent6cf3706f85af0be07d31317bb57bf08d3b70080a (diff)
downloadmaster-31e0f0ae-c84a5161c5e4c5ea71715f60b937d8cf45592fde.tar.gz
master-31e0f0ae-c84a5161c5e4c5ea71715f60b937d8cf45592fde.tar.bz2
master-31e0f0ae-c84a5161c5e4c5ea71715f60b937d8cf45592fde.zip
add support for the OpenRB Light board
SVN-Revision: 16908
Diffstat (limited to 'target/linux/ppc40x/image')
-rw-r--r--target/linux/ppc40x/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
index a5be9be92a..60d85bffdd 100644
--- a/target/linux/ppc40x/image/Makefile
+++ b/target/linux/ppc40x/image/Makefile
@@ -39,6 +39,10 @@ define Image/Build/jffs2-64k
dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1152k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv2-jffs2.img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb-light bs=1152k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-light-jffs2.img
endef
define Image/Build/squashfs
@@ -56,6 +60,10 @@ define Image/Build/squashfs
dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1152k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv2-$(1).img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb-light bs=1152k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-light-$(1).img
endef
$(eval $(call BuildImage))