summaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-11-26 10:06:34 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-11-26 10:06:34 +0000
commitb359ab764fadb724e6e9c83624feb46354225c2c (patch)
treed20d480d0df7bfb090549a698ef54a657cecf05b /target/linux/ppc40x/image
parent8375b830152d7e38e385bf7b9b0fa31cf197628b (diff)
downloadmaster-31e0f0ae-b359ab764fadb724e6e9c83624feb46354225c2c.tar.gz
master-31e0f0ae-b359ab764fadb724e6e9c83624feb46354225c2c.tar.bz2
master-31e0f0ae-b359ab764fadb724e6e9c83624feb46354225c2c.zip
nuke the magicbox target and incorporate a rewritten port into ppc40x - note: no CF driver for now
SVN-Revision: 13358
Diffstat (limited to 'target/linux/ppc40x/image')
-rw-r--r--target/linux/ppc40x/image/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
index ce3f136583..b54cc06488 100644
--- a/target/linux/ppc40x/image/Makefile
+++ b/target/linux/ppc40x/image/Makefile
@@ -27,7 +27,15 @@ define Image/Build/jffs2-128k
dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
dd if=$(KDIR)/openwrt-kilauea.dtb bs=128k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-jffs2.img
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-kilauea-jffs2.img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv1 bs=1024k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv1-jffs2.img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1024k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv2-jffs2.img
endef
define Image/Build/squashfs
@@ -36,7 +44,15 @@ define Image/Build/squashfs
dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
dd if=$(KDIR)/openwrt-kilauea.dtb bs=128k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-kilauea-$(1).img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv1 bs=1024k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv1-$(1).img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1024k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv2-$(1).img
endef
$(eval $(call BuildImage))