summaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-07-26 16:15:26 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-07-26 16:15:26 +0000
commitb2afb336a29439d84a30a694333e902499f610d0 (patch)
tree43e4928b8a26c9d458602748638cfaaec503fb5b /target/linux/ppc40x/image
parentb18a60e1accf47ea1bd2567f7ee0988f0750ddcd (diff)
downloadmaster-31e0f0ae-b2afb336a29439d84a30a694333e902499f610d0.tar.gz
master-31e0f0ae-b2afb336a29439d84a30a694333e902499f610d0.tar.bz2
master-31e0f0ae-b2afb336a29439d84a30a694333e902499f610d0.zip
allow creating of ext2 filesystems
SVN-Revision: 17017
Diffstat (limited to 'target/linux/ppc40x/image')
-rw-r--r--target/linux/ppc40x/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
index d9586dd153..3afeeca4ad 100644
--- a/target/linux/ppc40x/image/Makefile
+++ b/target/linux/ppc40x/image/Makefile
@@ -22,6 +22,10 @@ define Image/Build
$(call Image/Build/$(1),$(1))
endef
+define Image/Build/ext2
+ cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-ext2.img
+endef
+
define Image/Build/jffs2-128k
( \
dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \