summaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-04-18 08:32:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-04-18 08:32:35 +0000
commit8d86dbb4541aa050c072bb88cc8b137365ba18c6 (patch)
treed9ea398ab64224ff492edc1dfa12290eb2b8b3cf /target/linux/ppc40x/image
parent857ed7b676a241ad304166d2a7c7cdb7a2e58da6 (diff)
downloadmaster-31e0f0ae-8d86dbb4541aa050c072bb88cc8b137365ba18c6.tar.gz
master-31e0f0ae-8d86dbb4541aa050c072bb88cc8b137365ba18c6.tar.bz2
master-31e0f0ae-8d86dbb4541aa050c072bb88cc8b137365ba18c6.zip
ppc40x: build initramfs images for the OpenRB/Magicbox boards
SVN-Revision: 20980
Diffstat (limited to 'target/linux/ppc40x/image')
-rw-r--r--target/linux/ppc40x/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
index 3e355a98e7..415539e9cc 100644
--- a/target/linux/ppc40x/image/Makefile
+++ b/target/linux/ppc40x/image/Makefile
@@ -16,6 +16,7 @@ endef
define Image/BuildKernel
cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
+ $(call Image/Build/Initramfs)
endef
define Image/Build
@@ -62,4 +63,11 @@ define Image/Build/squashfs
) > $(BIN_DIR)/$(IMG_PREFIX)-openrb-$(1).img
endef
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+define Image/Build/Initramfs
+ cp $(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox $(BIN_DIR)/openwrt-$(BOARD)-magicbox-initramfs.bin
+ cp $(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb $(BIN_DIR)/openwrt-$(BOARD)-openrb-initramfs.bin
+endef
+endif
+
$(eval $(call BuildImage))