summaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-24 20:01:54 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-24 20:01:54 +0000
commit03aef1e2c5c4372be96faf93cc5478bbedf80e59 (patch)
tree31339179bf5158ea53be0ab61bbe26299422e076 /target/linux/ppc40x/image
parentea6665874f93fcdde7ad6d27754f1b814f177862 (diff)
downloadmaster-31e0f0ae-03aef1e2c5c4372be96faf93cc5478bbedf80e59.tar.gz
master-31e0f0ae-03aef1e2c5c4372be96faf93cc5478bbedf80e59.tar.bz2
master-31e0f0ae-03aef1e2c5c4372be96faf93cc5478bbedf80e59.zip
add support for the OpenRB Medium board
SVN-Revision: 16970
Diffstat (limited to 'target/linux/ppc40x/image')
-rw-r--r--target/linux/ppc40x/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
index 60d85bffdd..d9586dd153 100644
--- a/target/linux/ppc40x/image/Makefile
+++ b/target/linux/ppc40x/image/Makefile
@@ -43,6 +43,10 @@ define Image/Build/jffs2-64k
dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb-light bs=1152k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-light-jffs2.img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb-medium bs=1152k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-medium-jffs2.img
endef
define Image/Build/squashfs
@@ -64,6 +68,10 @@ define Image/Build/squashfs
dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb-light bs=1152k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-light-$(1).img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb-medium bs=1152k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-medium-$(1).img
endef
$(eval $(call BuildImage))