summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2016-04-19 20:14:31 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2016-04-19 20:14:31 +0000
commit95f0d4fcfdc653f7f9eb3274c1ccd21f50d2ac2e (patch)
treef5f679d5e317e5a03161c16ba26bc95726aa346b /target/linux/oxnas
parent012da658a4565b60d2cae8d888fcd487c8ecfac9 (diff)
downloadmaster-31e0f0ae-95f0d4fcfdc653f7f9eb3274c1ccd21f50d2ac2e.tar.gz
master-31e0f0ae-95f0d4fcfdc653f7f9eb3274c1ccd21f50d2ac2e.tar.bz2
master-31e0f0ae-95f0d4fcfdc653f7f9eb3274c1ccd21f50d2ac2e.zip
oxnas: clean-up and improve profiles
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 49198
Diffstat (limited to 'target/linux/oxnas')
-rw-r--r--target/linux/oxnas/profiles/00-default.mk9
-rw-r--r--target/linux/oxnas/profiles/cloudengines.mk (renamed from target/linux/oxnas/profiles/pogoplug.mk)8
2 files changed, 10 insertions, 7 deletions
diff --git a/target/linux/oxnas/profiles/00-default.mk b/target/linux/oxnas/profiles/00-default.mk
index fb04ba788c..67f866ee80 100644
--- a/target/linux/oxnas/profiles/00-default.mk
+++ b/target/linux/oxnas/profiles/00-default.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,11 +8,14 @@
define Profile/Default
NAME:=Default Profile
PACKAGES:=\
- kmod-usb-core kmod-usb3 \
- kmod-ledtrig-usbdev
+ kmod-usb-core kmod-usb3 kmod-ledtrig-usbdev \
+ kmod-usb-storage \
+ kmod-i2c-gpio kmod-rtc-pcf8563 kmod-rtc-ds1307 \
+ kmod-gpio-beeper kmod-hwmon-core kmod-hwmon-gpiofan
endef
define Profile/Default/Description
Default package set compatible with most boards.
endef
+
$(eval $(call Profile,Default))
diff --git a/target/linux/oxnas/profiles/pogoplug.mk b/target/linux/oxnas/profiles/cloudengines.mk
index dcab128ef1..ed0a235254 100644
--- a/target/linux/oxnas/profiles/pogoplug.mk
+++ b/target/linux/oxnas/profiles/cloudengines.mk
@@ -5,20 +5,20 @@
#
define Profile/POGOPLUG_PRO
- NAME:=PogoPlug Pro
+ NAME:=Cloud Engines Pogoplug Pro
endef
define Profile/POGOPLUG_PRO/Description
- Profile with built-in ox820 PogoPlug Pro device-tree
+ Profile with built-in ox820 Pogoplug Pro device-tree
(board with miniPCIe slot)
endef
define Profile/POGOPLUG_V3
- NAME:=PogoPlug V3
+ NAME:=Cloud Engines Pogoplug V3
endef
define Profile/POGOPLUG_V3/Description
- Profile with built-in ox820 PogoPlug V3 device-tree
+ Profile with built-in ox820 Pogoplug V3 device-tree
(board without miniPCIe slot)
endef