summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-20 14:41:13 +0000
committerJohn Crispin <john@openwrt.org>2016-03-20 14:41:13 +0000
commit3cea0747d6ffd0d791f9c32e4d1c09f58aed0fac (patch)
tree18dbe92a05ac307ee0aab849a5d494a4cc8616bf /target/linux/oxnas
parent4fe3fda78af4c9ebad06d8efc342ce58237cc44a (diff)
downloadmaster-31e0f0ae-3cea0747d6ffd0d791f9c32e4d1c09f58aed0fac.tar.gz
master-31e0f0ae-3cea0747d6ffd0d791f9c32e4d1c09f58aed0fac.tar.bz2
master-31e0f0ae-3cea0747d6ffd0d791f9c32e4d1c09f58aed0fac.zip
oxnas: add Default profile and reorganize device profiles
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 49040
Diffstat (limited to 'target/linux/oxnas')
-rw-r--r--target/linux/oxnas/profiles/00-default.mk18
-rw-r--r--target/linux/oxnas/profiles/mitrastar.mk15
-rw-r--r--target/linux/oxnas/profiles/pogoplug.mk (renamed from target/linux/oxnas/profiles/100-Generic.mk)24
-rw-r--r--target/linux/oxnas/profiles/shuttle.mk18
4 files changed, 52 insertions, 23 deletions
diff --git a/target/linux/oxnas/profiles/00-default.mk b/target/linux/oxnas/profiles/00-default.mk
new file mode 100644
index 0000000000..fb04ba788c
--- /dev/null
+++ b/target/linux/oxnas/profiles/00-default.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/oxnas/profiles/mitrastar.mk b/target/linux/oxnas/profiles/mitrastar.mk
new file mode 100644
index 0000000000..1991c9b688
--- /dev/null
+++ b/target/linux/oxnas/profiles/mitrastar.mk
@@ -0,0 +1,15 @@
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/STG212
+ NAME:=MitraStar STG-212
+endef
+
+define Profile/STG212/Description
+ Profile with built-in ox820 STG-212 device-tree
+endef
+
+$(eval $(call Profile,STG212))
diff --git a/target/linux/oxnas/profiles/100-Generic.mk b/target/linux/oxnas/profiles/pogoplug.mk
index 5304839754..dcab128ef1 100644
--- a/target/linux/oxnas/profiles/100-Generic.mk
+++ b/target/linux/oxnas/profiles/pogoplug.mk
@@ -1,5 +1,4 @@
-#
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -23,26 +22,5 @@ define Profile/POGOPLUG_V3/Description
(board without miniPCIe slot)
endef
-define Profile/STG212
- NAME:=MitraStar STG-212
-endef
-
-define Profile/STG212/Description
- Profile with built-in ox820 STG-212 device-tree
-endef
-
-define Profile/KD20
- NAME:=Shuttle KD20
- PACKAGES:= \
- kmod-usb3 kmod-usb-storage kmod-i2c-gpio kmod-rtc-pcf8563 \
- kmod-gpio-beeper kmod-hwmon-core kmod-hwmon-gpiofan
-endef
-
-define Profile/KD20/Description
- Profile with built-in ox820 KD20 device-tree
-endef
-
$(eval $(call Profile,POGOPLUG_PRO))
$(eval $(call Profile,POGOPLUG_V3))
-$(eval $(call Profile,STG212))
-$(eval $(call Profile,KD20))
diff --git a/target/linux/oxnas/profiles/shuttle.mk b/target/linux/oxnas/profiles/shuttle.mk
new file mode 100644
index 0000000000..a83935f9c5
--- /dev/null
+++ b/target/linux/oxnas/profiles/shuttle.mk
@@ -0,0 +1,18 @@
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/KD20
+ NAME:=Shuttle KD20
+ PACKAGES:= \
+ kmod-usb3 kmod-usb-storage kmod-i2c-gpio kmod-rtc-pcf8563 \
+ kmod-gpio-beeper kmod-hwmon-core kmod-hwmon-gpiofan
+endef
+
+define Profile/KD20/Description
+ Profile with built-in ox820 KD20 device-tree
+endef
+
+$(eval $(call Profile,KD20))