summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-05-16 20:27:45 +0200
committerDaniel Golle <daniel@makrotopia.org>2016-05-17 17:26:05 +0200
commit055d8d9c61de5dc3342755384cd6f0f62553ebdc (patch)
tree268a6a0c55e7207b6734225fa03fe80a8e3f4e11 /target/linux/oxnas
parent17de501daabda6f5a1cb9c539bc3c3f885aeca10 (diff)
downloadmaster-31e0f0ae-055d8d9c61de5dc3342755384cd6f0f62553ebdc.tar.gz
master-31e0f0ae-055d8d9c61de5dc3342755384cd6f0f62553ebdc.tar.bz2
master-31e0f0ae-055d8d9c61de5dc3342755384cd6f0f62553ebdc.zip
oxnas: move target-specific modules into target's modules.mk
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/oxnas')
-rw-r--r--target/linux/oxnas/modules.mk41
1 files changed, 41 insertions, 0 deletions
diff --git a/target/linux/oxnas/modules.mk b/target/linux/oxnas/modules.mk
new file mode 100644
index 0000000000..7016398619
--- /dev/null
+++ b/target/linux/oxnas/modules.mk
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2016 LEDE project
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/ata-oxnas-sata
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=oxnas Serial ATA support
+ KCONFIG:=CONFIG_SATA_OXNAS
+ DEPENDS:=@TARGET_oxnas
+ FILES:=$(LINUX_DIR)/drivers/ata/sata_oxnas.ko
+ AUTOLOAD:=$(call AutoLoad,41,sata_oxnas,1)
+ $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-oxnas-sata/description
+ SATA support for OX934 core found in the OX82x/PLX782x SoCs
+endef
+
+$(eval $(call KernelPackage,ata-oxnas-sata))
+
+
+define KernelPackage/usb2-oxnas
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=OXNAS USB controller driver
+ DEPENDS:=@TARGET_oxnas +kmod-usb2
+ KCONFIG:=CONFIG_USB_EHCI_OXNAS
+ FILES:=$(LINUX_DIR)/drivers/usb/host/ehci-oxnas.ko
+ AUTOLOAD:=$(call AutoLoad,55,ehci-oxnas,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb2-oxnas/description
+ This driver provides USB Device Controller support for the
+ EHCI USB host built-in to the PLXTECH NAS782x SoC
+endef
+
+$(eval $(call KernelPackage,usb2-oxnas))