summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-05-21 19:32:46 +0000
committerJonas Gorski <jogo@openwrt.org>2015-05-21 19:32:46 +0000
commit76d079204df113afa9e382a43abb5e1a2135150d (patch)
tree8e472ab203e8d6a47dc2e285b3becbfca35d04c6 /target/linux/oxnas
parent072937888e133f5e97fd05a7496eaf7eeae04079 (diff)
downloadmaster-31e0f0ae-76d079204df113afa9e382a43abb5e1a2135150d.tar.gz
master-31e0f0ae-76d079204df113afa9e382a43abb5e1a2135150d.tar.bz2
master-31e0f0ae-76d079204df113afa9e382a43abb5e1a2135150d.zip
kernel: update 3.18 to 3.18.14
Changelogs: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.12 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.13 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.14 Build tested on brcm63xx and ipq806x, runtested on brcm63xx. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 45711
Diffstat (limited to 'target/linux/oxnas')
-rw-r--r--target/linux/oxnas/patches-3.18/010-arm_introduce-dma-fiq-irq-broadcast.patch20
-rw-r--r--target/linux/oxnas/patches-3.18/250-add-plxtech-vendor-prefix.patch8
-rw-r--r--target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch30
-rw-r--r--target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch12
-rw-r--r--target/linux/oxnas/patches-3.18/320-oxnas-irqchip.patch18
-rw-r--r--target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch12
-rw-r--r--target/linux/oxnas/patches-3.18/340-oxnas-pcie.patch12
-rw-r--r--target/linux/oxnas/patches-3.18/350-oxnas-reset.patch12
-rw-r--r--target/linux/oxnas/patches-3.18/400-oxnas-nand.patch12
-rw-r--r--target/linux/oxnas/patches-3.18/500-oxnas-sata.patch14
-rw-r--r--target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch12
-rw-r--r--target/linux/oxnas/patches-3.18/900-more-boards.patch6
-rw-r--r--target/linux/oxnas/patches-3.18/999-libata-hacks.patch26
13 files changed, 68 insertions, 126 deletions
diff --git a/target/linux/oxnas/patches-3.18/010-arm_introduce-dma-fiq-irq-broadcast.patch b/target/linux/oxnas/patches-3.18/010-arm_introduce-dma-fiq-irq-broadcast.patch
index fb7547f96b..1ce68e8276 100644
--- a/target/linux/oxnas/patches-3.18/010-arm_introduce-dma-fiq-irq-broadcast.patch
+++ b/target/linux/oxnas/patches-3.18/010-arm_introduce-dma-fiq-irq-broadcast.patch
@@ -1,7 +1,5 @@
-Index: linux-3.18-rc4/arch/arm/include/asm/glue-cache.h
-===================================================================
---- linux-3.18-rc4.orig/arch/arm/include/asm/glue-cache.h
-+++ linux-3.18-rc4/arch/arm/include/asm/glue-cache.h
+--- a/arch/arm/include/asm/glue-cache.h
++++ b/arch/arm/include/asm/glue-cache.h
@@ -156,11 +156,19 @@ static inline void nop_dma_unmap_area(co
#define __cpuc_flush_user_range __glue(_CACHE,_flush_user_cache_range)
#define __cpuc_coherent_kern_range __glue(_CACHE,_coherent_kern_range)
@@ -22,11 +20,9 @@ Index: linux-3.18-rc4/arch/arm/include/asm/glue-cache.h
#endif
#endif
-Index: linux-3.18-rc4/arch/arm/mm/Kconfig
-===================================================================
---- linux-3.18-rc4.orig/arch/arm/mm/Kconfig
-+++ linux-3.18-rc4/arch/arm/mm/Kconfig
-@@ -843,6 +843,17 @@ config DMA_CACHE_RWFO
+--- a/arch/arm/mm/Kconfig
++++ b/arch/arm/mm/Kconfig
+@@ -844,6 +844,17 @@ config DMA_CACHE_RWFO
in hardware, other workarounds are needed (e.g. cache
maintenance broadcasting in software via FIQ).
@@ -44,10 +40,8 @@ Index: linux-3.18-rc4/arch/arm/mm/Kconfig
config OUTER_CACHE
bool
-Index: linux-3.18-rc4/arch/arm/mm/flush.c
-===================================================================
---- linux-3.18-rc4.orig/arch/arm/mm/flush.c
-+++ linux-3.18-rc4/arch/arm/mm/flush.c
+--- a/arch/arm/mm/flush.c
++++ b/arch/arm/mm/flush.c
@@ -314,7 +314,11 @@ void flush_dcache_page(struct page *page
mapping = page_mapping(page);
diff --git a/target/linux/oxnas/patches-3.18/250-add-plxtech-vendor-prefix.patch b/target/linux/oxnas/patches-3.18/250-add-plxtech-vendor-prefix.patch
index c495258d30..1645c883d3 100644
--- a/target/linux/oxnas/patches-3.18/250-add-plxtech-vendor-prefix.patch
+++ b/target/linux/oxnas/patches-3.18/250-add-plxtech-vendor-prefix.patch
@@ -1,8 +1,6 @@
-Index: linux-3.18-rc4/Documentation/devicetree/bindings/vendor-prefixes.txt
-===================================================================
---- linux-3.18-rc4.orig/Documentation/devicetree/bindings/vendor-prefixes.txt
-+++ linux-3.18-rc4/Documentation/devicetree/bindings/vendor-prefixes.txt
-@@ -113,6 +113,7 @@ panasonic Panasonic Corporation
+--- a/Documentation/devicetree/bindings/vendor-prefixes.txt
++++ b/Documentation/devicetree/bindings/vendor-prefixes.txt
+@@ -115,6 +115,7 @@ panasonic Panasonic Corporation
phytec PHYTEC Messtechnik GmbH
picochip Picochip Ltd
plathome Plat'Home Co., Ltd.
diff --git a/target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch b/target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch
index 17ec83b63f..5724263d3f 100644
--- a/target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch
+++ b/target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch
@@ -1,7 +1,5 @@
-Index: linux-3.18-rc4/arch/arm/Kconfig
-===================================================================
---- linux-3.18-rc4.orig/arch/arm/Kconfig
-+++ linux-3.18-rc4/arch/arm/Kconfig
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
@@ -369,6 +369,17 @@ config ARCH_VERSATILE
help
This enables support for ARM Ltd Versatile board.
@@ -29,10 +27,8 @@ Index: linux-3.18-rc4/arch/arm/Kconfig
source "arch/arm/mach-picoxcell/Kconfig"
source "arch/arm/mach-pxa/Kconfig"
-Index: linux-3.18-rc4/arch/arm/Makefile
-===================================================================
---- linux-3.18-rc4.orig/arch/arm/Makefile
-+++ linux-3.18-rc4/arch/arm/Makefile
+--- a/arch/arm/Makefile
++++ b/arch/arm/Makefile
@@ -187,6 +187,7 @@ machine-$(CONFIG_ARCH_NSPIRE) += nspire
machine-$(CONFIG_ARCH_OMAP1) += omap1
machine-$(CONFIG_ARCH_OMAP2PLUS) += omap2
@@ -41,10 +37,8 @@ Index: linux-3.18-rc4/arch/arm/Makefile
machine-$(CONFIG_ARCH_PICOXCELL) += picoxcell
machine-$(CONFIG_ARCH_PXA) += pxa
machine-$(CONFIG_ARCH_QCOM) += qcom
-Index: linux-3.18-rc4/arch/arm/boot/dts/Makefile
-===================================================================
---- linux-3.18-rc4.orig/arch/arm/boot/dts/Makefile
-+++ linux-3.18-rc4/arch/arm/boot/dts/Makefile
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
@@ -352,6 +352,7 @@ dtb-$(CONFIG_ARCH_ORION5X) += orion5x-la
orion5x-lacie-ethernet-disk-mini-v2.dtb \
orion5x-maxtor-shared-storage-2.dtb \
@@ -53,10 +47,8 @@ Index: linux-3.18-rc4/arch/arm/boot/dts/Makefile
dtb-$(CONFIG_ARCH_PRIMA2) += prima2-evb.dtb
dtb-$(CONFIG_ARCH_QCOM) += \
qcom-apq8064-cm-qs600.dtb \
-Index: linux-3.18-rc4/arch/arm/tools/mach-types
-===================================================================
---- linux-3.18-rc4.orig/arch/arm/tools/mach-types
-+++ linux-3.18-rc4/arch/arm/tools/mach-types
+--- a/arch/arm/tools/mach-types
++++ b/arch/arm/tools/mach-types
@@ -228,6 +228,7 @@ edb9302a MACH_EDB9302A EDB9302A 1127
edb9307a MACH_EDB9307A EDB9307A 1128
omap_3430sdp MACH_OMAP_3430SDP OMAP_3430SDP 1138
@@ -65,10 +57,8 @@ Index: linux-3.18-rc4/arch/arm/tools/mach-types
micro9m MACH_MICRO9M MICRO9M 1169
bug MACH_BUG BUG 1179
at91sam9263ek MACH_AT91SAM9263EK AT91SAM9263EK 1202
-Index: linux-3.18-rc4/drivers/clk/Makefile
-===================================================================
---- linux-3.18-rc4.orig/drivers/clk/Makefile
-+++ linux-3.18-rc4/drivers/clk/Makefile
+--- a/drivers/clk/Makefile
++++ b/drivers/clk/Makefile
@@ -29,6 +29,7 @@ obj-$(CONFIG_COMMON_CLK_MAX77802) += clk
obj-$(CONFIG_ARCH_MOXART) += clk-moxart.o
obj-$(CONFIG_ARCH_NOMADIK) += clk-nomadik.o
diff --git a/target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch b/target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch
index 0959e53648..e10b38c192 100644
--- a/target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch
+++ b/target/linux/oxnas/patches-3.18/310-oxnas-clocksource.patch
@@ -1,7 +1,5 @@
-Index: linux-3.18-rc4/drivers/clocksource/Kconfig
-===================================================================
---- linux-3.18-rc4.orig/drivers/clocksource/Kconfig
-+++ linux-3.18-rc4/drivers/clocksource/Kconfig
+--- a/drivers/clocksource/Kconfig
++++ b/drivers/clocksource/Kconfig
@@ -156,6 +156,12 @@ config VF_PIT_TIMER
help
Support for Period Interrupt Timer on Freescale Vybrid Family SoCs.
@@ -15,10 +13,8 @@ Index: linux-3.18-rc4/drivers/clocksource/Kconfig
config SYS_SUPPORTS_SH_CMT
bool
-Index: linux-3.18-rc4/drivers/clocksource/Makefile
-===================================================================
---- linux-3.18-rc4.orig/drivers/clocksource/Makefile
-+++ linux-3.18-rc4/drivers/clocksource/Makefile
+--- a/drivers/clocksource/Makefile
++++ b/drivers/clocksource/Makefile
@@ -36,6 +36,7 @@ obj-$(CONFIG_CLKSRC_EFM32) += time-efm32
obj-$(CONFIG_CLKSRC_EXYNOS_MCT) += exynos_mct.o
obj-$(CONFIG_CLKSRC_SAMSUNG_PWM) += samsung_pwm_timer.o
diff --git a/target/linux/oxnas/patches-3.18/320-oxnas-irqchip.patch b/target/linux/oxnas/patches-3.18/320-oxnas-irqchip.patch
index e6262da78d..5e130bea81 100644
--- a/target/linux/oxnas/patches-3.18/320-oxnas-irqchip.patch
+++ b/target/linux/oxnas/patches-3.18/320-oxnas-irqchip.patch
@@ -1,7 +1,5 @@
-Index: linux-3.18-rc4/drivers/irqchip/Kconfig
-===================================================================
---- linux-3.18-rc4.orig/drivers/irqchip/Kconfig
-+++ linux-3.18-rc4/drivers/irqchip/Kconfig
+--- a/drivers/irqchip/Kconfig
++++ b/drivers/irqchip/Kconfig
@@ -15,6 +15,11 @@ config ARM_GIC_V3
select IRQ_DOMAIN
select MULTI_IRQ_HANDLER
@@ -14,10 +12,8 @@ Index: linux-3.18-rc4/drivers/irqchip/Kconfig
config ARM_NVIC
bool
select IRQ_DOMAIN
-Index: linux-3.18-rc4/drivers/irqchip/Makefile
-===================================================================
---- linux-3.18-rc4.orig/drivers/irqchip/Makefile
-+++ linux-3.18-rc4/drivers/irqchip/Makefile
+--- a/drivers/irqchip/Makefile
++++ b/drivers/irqchip/Makefile
@@ -28,6 +28,7 @@ obj-$(CONFIG_IMGPDC_IRQ) += irq-imgpdc.
obj-$(CONFIG_SIRF_IRQ) += irq-sirfsoc.o
obj-$(CONFIG_RENESAS_INTC_IRQPIN) += irq-renesas-intc-irqpin.o
@@ -26,10 +22,8 @@ Index: linux-3.18-rc4/drivers/irqchip/Makefile
obj-$(CONFIG_VERSATILE_FPGA_IRQ) += irq-versatile-fpga.o
obj-$(CONFIG_ARCH_NSPIRE) += irq-zevio.o
obj-$(CONFIG_ARCH_VT8500) += irq-vt8500.o
-Index: linux-3.18-rc4/drivers/irqchip/irq-gic.c
-===================================================================
---- linux-3.18-rc4.orig/drivers/irqchip/irq-gic.c
-+++ linux-3.18-rc4/drivers/irqchip/irq-gic.c
+--- a/drivers/irqchip/irq-gic.c
++++ b/drivers/irqchip/irq-gic.c
@@ -1044,6 +1044,7 @@ IRQCHIP_DECLARE(gic_400, "arm,gic-400",
IRQCHIP_DECLARE(cortex_a15_gic, "arm,cortex-a15-gic", gic_of_init);
IRQCHIP_DECLARE(cortex_a9_gic, "arm,cortex-a9-gic", gic_of_init);
diff --git a/target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch b/target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch
index 3ecc6ebe77..1bca799b8a 100644
--- a/target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch
+++ b/target/linux/oxnas/patches-3.18/330-oxnas-pinctrl.patch
@@ -1,7 +1,5 @@
-Index: linux-3.18-rc4/drivers/pinctrl/Kconfig
-===================================================================
---- linux-3.18-rc4.orig/drivers/pinctrl/Kconfig
-+++ linux-3.18-rc4/drivers/pinctrl/Kconfig
+--- a/drivers/pinctrl/Kconfig
++++ b/drivers/pinctrl/Kconfig
@@ -67,6 +67,15 @@ config PINCTRL_AT91
help
Say Y here to enable the at91 pinctrl driver
@@ -18,10 +16,8 @@ Index: linux-3.18-rc4/drivers/pinctrl/Kconfig
config PINCTRL_BAYTRAIL
bool "Intel Baytrail GPIO pin control"
depends on GPIOLIB && ACPI && X86
-Index: linux-3.18-rc4/drivers/pinctrl/Makefile
-===================================================================
---- linux-3.18-rc4.orig/drivers/pinctrl/Makefile
-+++ linux-3.18-rc4/drivers/pinctrl/Makefile
+--- a/drivers/pinctrl/Makefile
++++ b/drivers/pinctrl/Makefile
@@ -18,6 +18,7 @@ obj-$(CONFIG_PINCTRL_BCM2835) += pinctrl
obj-$(CONFIG_PINCTRL_BAYTRAIL) += pinctrl-baytrail.o
obj-$(CONFIG_PINCTRL_BCM281XX) += pinctrl-bcm281xx.o
diff --git a/target/linux/oxnas/patches-3.18/340-oxnas-pcie.patch b/target/linux/oxnas/patches-3.18/340-oxnas-pcie.patch
index 6549db01a9..b54f00e38a 100644
--- a/target/linux/oxnas/patches-3.18/340-oxnas-pcie.patch
+++ b/target/linux/oxnas/patches-3.18/340-oxnas-pcie.patch
@@ -1,7 +1,5 @@
-Index: linux-3.18-rc4/drivers/pci/host/Kconfig
-===================================================================
---- linux-3.18-rc4.orig/drivers/pci/host/Kconfig
-+++ linux-3.18-rc4/drivers/pci/host/Kconfig
+--- a/drivers/pci/host/Kconfig
++++ b/drivers/pci/host/Kconfig
@@ -91,4 +91,9 @@ config PCI_XGENE
There are 5 internal PCIe ports available. Each port is GEN3 capable
and have varied lanes from x1 to x8.
@@ -12,10 +10,8 @@ Index: linux-3.18-rc4/drivers/pci/host/Kconfig
+ select PCIEPORTBUS
+
endmenu
-Index: linux-3.18-rc4/drivers/pci/host/Makefile
-===================================================================
---- linux-3.18-rc4.orig/drivers/pci/host/Makefile
-+++ linux-3.18-rc4/drivers/pci/host/Makefile
+--- a/drivers/pci/host/Makefile
++++ b/drivers/pci/host/Makefile
@@ -3,6 +3,7 @@ obj-$(CONFIG_PCI_DRA7XX) += pci-dra7xx.o
obj-$(CONFIG_PCI_EXYNOS) += pci-exynos.o
obj-$(CONFIG_PCI_IMX6) += pci-imx6.o
diff --git a/target/linux/oxnas/patches-3.18/350-oxnas-reset.patch b/target/linux/oxnas/patches-3.18/350-oxnas-reset.patch
index 5540920414..c29423756f 100644
--- a/target/linux/oxnas/patches-3.18/350-oxnas-reset.patch
+++ b/target/linux/oxnas/patches-3.18/350-oxnas-reset.patch
@@ -1,7 +1,5 @@
-Index: linux-3.18-rc4/drivers/reset/Kconfig
-===================================================================
---- linux-3.18-rc4.orig/drivers/reset/Kconfig
-+++ linux-3.18-rc4/drivers/reset/Kconfig
+--- a/drivers/reset/Kconfig
++++ b/drivers/reset/Kconfig
@@ -12,4 +12,9 @@ menuconfig RESET_CONTROLLER
If unsure, say no.
@@ -12,10 +10,8 @@ Index: linux-3.18-rc4/drivers/reset/Kconfig
+
source "drivers/reset/sti/Kconfig"
+
-Index: linux-3.18-rc4/drivers/reset/Makefile
-===================================================================
---- linux-3.18-rc4.orig/drivers/reset/Makefile
-+++ linux-3.18-rc4/drivers/reset/Makefile
+--- a/drivers/reset/Makefile
++++ b/drivers/reset/Makefile
@@ -1,4 +1,5 @@
obj-$(CONFIG_RESET_CONTROLLER) += core.o
+obj-$(CONFIG_RESET_CONTROLLER_OXNAS) += reset-ox820.o
diff --git a/target/linux/oxnas/patches-3.18/400-oxnas-nand.patch b/target/linux/oxnas/patches-3.18/400-oxnas-nand.patch
index 90827e5b8a..779e74b87e 100644
--- a/target/linux/oxnas/patches-3.18/400-oxnas-nand.patch
+++ b/target/linux/oxnas/patches-3.18/400-oxnas-nand.patch
@@ -1,7 +1,5 @@
-Index: linux-3.18-rc4/drivers/mtd/nand/Kconfig
-===================================================================
---- linux-3.18-rc4.orig/drivers/mtd/nand/Kconfig
-+++ linux-3.18-rc4/drivers/mtd/nand/Kconfig
+--- a/drivers/mtd/nand/Kconfig
++++ b/drivers/mtd/nand/Kconfig
@@ -516,4 +516,12 @@ config MTD_NAND_XWAY
Enables support for NAND Flash chips on Lantiq XWAY SoCs. NAND is attached
to the External Bus Unit (EBU).
@@ -15,10 +13,8 @@ Index: linux-3.18-rc4/drivers/mtd/nand/Kconfig
+ to the STATIC Unit.
+
endif # MTD_NAND
-Index: linux-3.18-rc4/drivers/mtd/nand/Makefile
-===================================================================
---- linux-3.18-rc4.orig/drivers/mtd/nand/Makefile
-+++ linux-3.18-rc4/drivers/mtd/nand/Makefile
+--- a/drivers/mtd/nand/Makefile
++++ b/drivers/mtd/nand/Makefile
@@ -50,5 +50,6 @@ obj-$(CONFIG_MTD_NAND_JZ4740) += jz4740
obj-$(CONFIG_MTD_NAND_GPMI_NAND) += gpmi-nand/
obj-$(CONFIG_MTD_NAND_XWAY) += xway_nand.o
diff --git a/target/linux/oxnas/patches-3.18/500-oxnas-sata.patch b/target/linux/oxnas/patches-3.18/500-oxnas-sata.patch
index 94b792b136..af5e66ff03 100644
--- a/target/linux/oxnas/patches-3.18/500-oxnas-sata.patch
+++ b/target/linux/oxnas/patches-3.18/500-oxnas-sata.patch
@@ -1,8 +1,6 @@
-Index: linux-3.18-rc4/drivers/ata/Kconfig
-===================================================================
---- linux-3.18-rc4.orig/drivers/ata/Kconfig
-+++ linux-3.18-rc4/drivers/ata/Kconfig
-@@ -385,6 +385,13 @@ config SATA_VITESSE
+--- a/drivers/ata/Kconfig
++++ b/drivers/ata/Kconfig
+@@ -401,6 +401,13 @@ config SATA_VITESSE
If unsure, say N.
@@ -16,10 +14,8 @@ Index: linux-3.18-rc4/drivers/ata/Kconfig
comment "PATA SFF controllers with BMDMA"
config PATA_ALI
-Index: linux-3.18-rc4/drivers/ata/Makefile
-===================================================================
---- linux-3.18-rc4.orig/drivers/ata/Makefile
-+++ linux-3.18-rc4/drivers/ata/Makefile
+--- a/drivers/ata/Makefile
++++ b/drivers/ata/Makefile
@@ -37,6 +37,7 @@ obj-$(CONFIG_SATA_SVW) += sata_svw.o
obj-$(CONFIG_SATA_ULI) += sata_uli.o
obj-$(CONFIG_SATA_VIA) += sata_via.o
diff --git a/target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch b/target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch
index f2221dda88..b9be0c6127 100644
--- a/target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch
+++ b/target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch
@@ -1,7 +1,5 @@
-Index: linux-3.18-rc4/drivers/usb/host/Kconfig
-===================================================================
---- linux-3.18-rc4.orig/drivers/usb/host/Kconfig
-+++ linux-3.18-rc4/drivers/usb/host/Kconfig
+--- a/drivers/usb/host/Kconfig
++++ b/drivers/usb/host/Kconfig
@@ -302,6 +302,13 @@ config USB_OCTEON_EHCI
USB 2.0 device support. All CN6XXX based chips with USB are
supported.
@@ -16,10 +14,8 @@ Index: linux-3.18-rc4/drivers/usb/host/Kconfig
endif # USB_EHCI_HCD
config USB_OXU210HP_HCD
-Index: linux-3.18-rc4/drivers/usb/host/Makefile
-===================================================================
---- linux-3.18-rc4.orig/drivers/usb/host/Makefile
-+++ linux-3.18-rc4/drivers/usb/host/Makefile
+--- a/drivers/usb/host/Makefile
++++ b/drivers/usb/host/Makefile
@@ -44,6 +44,7 @@ obj-$(CONFIG_USB_EHCI_HCD_AT91) += ehci-
obj-$(CONFIG_USB_EHCI_MSM) += ehci-msm.o
obj-$(CONFIG_USB_EHCI_TEGRA) += ehci-tegra.o
diff --git a/target/linux/oxnas/patches-3.18/900-more-boards.patch b/target/linux/oxnas/patches-3.18/900-more-boards.patch
index b31967ad81..fab6936576 100644
--- a/target/linux/oxnas/patches-3.18/900-more-boards.patch
+++ b/target/linux/oxnas/patches-3.18/900-more-boards.patch
@@ -1,7 +1,5 @@
-Index: linux-3.18-rc4/arch/arm/boot/dts/Makefile
-===================================================================
---- linux-3.18-rc4.orig/arch/arm/boot/dts/Makefile
-+++ linux-3.18-rc4/arch/arm/boot/dts/Makefile
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
@@ -352,7 +352,10 @@ dtb-$(CONFIG_ARCH_ORION5X) += orion5x-la
orion5x-lacie-ethernet-disk-mini-v2.dtb \
orion5x-maxtor-shared-storage-2.dtb \
diff --git a/target/linux/oxnas/patches-3.18/999-libata-hacks.patch b/target/linux/oxnas/patches-3.18/999-libata-hacks.patch
index a1c80d89eb..741dddff40 100644
--- a/target/linux/oxnas/patches-3.18/999-libata-hacks.patch
+++ b/target/linux/oxnas/patches-3.18/999-libata-hacks.patch
@@ -1,8 +1,6 @@
-Index: linux-3.18-rc7/drivers/ata/libata-core.c
-===================================================================
---- linux-3.18-rc7.orig/drivers/ata/libata-core.c
-+++ linux-3.18-rc7/drivers/ata/libata-core.c
-@@ -1568,6 +1568,14 @@ unsigned ata_exec_internal_sg(struct ata
+--- a/drivers/ata/libata-core.c
++++ b/drivers/ata/libata-core.c
+@@ -1581,6 +1581,14 @@ unsigned ata_exec_internal_sg(struct ata
return AC_ERR_SYSTEM;
}
@@ -17,7 +15,7 @@ Index: linux-3.18-rc7/drivers/ata/libata-core.c
/* initialize internal qc */
/* XXX: Tag 0 is used for drivers with legacy EH as some
-@@ -4739,6 +4747,9 @@ static struct ata_queued_cmd *ata_qc_new
+@@ -4752,6 +4760,9 @@ static struct ata_queued_cmd *ata_qc_new
if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
return NULL;
@@ -25,9 +23,9 @@ Index: linux-3.18-rc7/drivers/ata/libata-core.c
+ return NULL;
+
for (i = 0, tag = ap->last_tag + 1; i < max_queue; i++, tag++) {
- tag = tag < max_queue ? tag : 0;
-
-@@ -4805,6 +4816,8 @@ void ata_qc_free(struct ata_queued_cmd *
+ if (ap->flags & ATA_FLAG_LOWTAG)
+ tag = i;
+@@ -4824,6 +4835,8 @@ void ata_qc_free(struct ata_queued_cmd *
if (likely(ata_tag_valid(tag))) {
qc->tag = ATA_TAG_POISON;
clear_bit(tag, &ap->qc_allocated);
@@ -36,11 +34,9 @@ Index: linux-3.18-rc7/drivers/ata/libata-core.c
}
}
-Index: linux-3.18-rc7/include/linux/libata.h
-===================================================================
---- linux-3.18-rc7.orig/include/linux/libata.h
-+++ linux-3.18-rc7/include/linux/libata.h
-@@ -884,6 +884,8 @@ struct ata_port_operations {
+--- a/include/linux/libata.h
++++ b/include/linux/libata.h
+@@ -891,6 +891,8 @@ struct ata_port_operations {
void (*qc_prep)(struct ata_queued_cmd *qc);
unsigned int (*qc_issue)(struct ata_queued_cmd *qc);
bool (*qc_fill_rtf)(struct ata_queued_cmd *qc);
@@ -49,7 +45,7 @@ Index: linux-3.18-rc7/include/linux/libata.h
/*
* Configuration and exception handling
-@@ -974,6 +976,9 @@ struct ata_port_operations {
+@@ -981,6 +983,9 @@ struct ata_port_operations {
void (*phy_reset)(struct ata_port *ap);
void (*eng_timeout)(struct ata_port *ap);