summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/profiles
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-05-15 04:31:25 +0200
committerDaniel Golle <daniel@makrotopia.org>2016-05-16 18:00:34 +0200
commit70eb03469f0406784b9be3204ef74e6d53e50a23 (patch)
tree5989f4cb9e73f50e11f9920e552255c032042b01 /target/linux/oxnas/profiles
parent449aba4fe849ce51c54c32689546e8d99da7f756 (diff)
downloadmaster-31e0f0ae-70eb03469f0406784b9be3204ef74e6d53e50a23.tar.gz
master-31e0f0ae-70eb03469f0406784b9be3204ef74e6d53e50a23.tar.bz2
master-31e0f0ae-70eb03469f0406784b9be3204ef74e6d53e50a23.zip
oxnas: reorganize image build code and nuke profiles
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/oxnas/profiles')
-rw-r--r--target/linux/oxnas/profiles/00-default.mk8
-rw-r--r--target/linux/oxnas/profiles/akitio.mk17
-rw-r--r--target/linux/oxnas/profiles/cloudengines.mk26
-rw-r--r--target/linux/oxnas/profiles/mitrastar.mk15
-rw-r--r--target/linux/oxnas/profiles/shuttle.mk18
5 files changed, 4 insertions, 80 deletions
diff --git a/target/linux/oxnas/profiles/00-default.mk b/target/linux/oxnas/profiles/00-default.mk
index 67f866ee80..fedf730088 100644
--- a/target/linux/oxnas/profiles/00-default.mk
+++ b/target/linux/oxnas/profiles/00-default.mk
@@ -7,11 +7,11 @@
define Profile/Default
NAME:=Default Profile
+ PRIORITY:=1
PACKAGES:=\
- kmod-usb-core kmod-usb3 kmod-ledtrig-usbdev \
- kmod-usb-storage \
- kmod-i2c-gpio kmod-rtc-pcf8563 kmod-rtc-ds1307 \
- kmod-gpio-beeper kmod-hwmon-core kmod-hwmon-gpiofan
+ kmod-i2c-gpio kmod-gpio-beeper kmod-hwmon-core \
+ kmod-hwmon-gpiofan kmod-rtc-pcf8563 kmod-rtc-ds1307 \
+ kmod-usb3
endef
define Profile/Default/Description
diff --git a/target/linux/oxnas/profiles/akitio.mk b/target/linux/oxnas/profiles/akitio.mk
deleted file mode 100644
index a10860101a..0000000000
--- a/target/linux/oxnas/profiles/akitio.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/AKITIO
- NAME:=Akitio MyCloud mini / Silverstone DC01
- PACKAGES:= \
- kmod-usb-storage kmod-i2c-gpio kmod-rtc-ds1307
-endef
-
-define Profile/AKITIO/Description
- Profile for the Akitio MyCloud mini aka. Silverstone DC01
-endef
-
-$(eval $(call Profile,AKITIO))
diff --git a/target/linux/oxnas/profiles/cloudengines.mk b/target/linux/oxnas/profiles/cloudengines.mk
deleted file mode 100644
index ed0a235254..0000000000
--- a/target/linux/oxnas/profiles/cloudengines.mk
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/POGOPLUG_PRO
- NAME:=Cloud Engines Pogoplug Pro
-endef
-
-define Profile/POGOPLUG_PRO/Description
- Profile with built-in ox820 Pogoplug Pro device-tree
- (board with miniPCIe slot)
-endef
-
-define Profile/POGOPLUG_V3
- NAME:=Cloud Engines Pogoplug V3
-endef
-
-define Profile/POGOPLUG_V3/Description
- Profile with built-in ox820 Pogoplug V3 device-tree
- (board without miniPCIe slot)
-endef
-
-$(eval $(call Profile,POGOPLUG_PRO))
-$(eval $(call Profile,POGOPLUG_V3))
diff --git a/target/linux/oxnas/profiles/mitrastar.mk b/target/linux/oxnas/profiles/mitrastar.mk
deleted file mode 100644
index 1991c9b688..0000000000
--- a/target/linux/oxnas/profiles/mitrastar.mk
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/STG212
- NAME:=MitraStar STG-212
-endef
-
-define Profile/STG212/Description
- Profile with built-in ox820 STG-212 device-tree
-endef
-
-$(eval $(call Profile,STG212))
diff --git a/target/linux/oxnas/profiles/shuttle.mk b/target/linux/oxnas/profiles/shuttle.mk
deleted file mode 100644
index a83935f9c5..0000000000
--- a/target/linux/oxnas/profiles/shuttle.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/KD20
- NAME:=Shuttle KD20
- PACKAGES:= \
- kmod-usb3 kmod-usb-storage kmod-i2c-gpio kmod-rtc-pcf8563 \
- kmod-gpio-beeper kmod-hwmon-core kmod-hwmon-gpiofan
-endef
-
-define Profile/KD20/Description
- Profile with built-in ox820 KD20 device-tree
-endef
-
-$(eval $(call Profile,KD20))