summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/profiles/cloudengines.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2016-04-19 20:14:31 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2016-04-19 20:14:31 +0000
commit95f0d4fcfdc653f7f9eb3274c1ccd21f50d2ac2e (patch)
treef5f679d5e317e5a03161c16ba26bc95726aa346b /target/linux/oxnas/profiles/cloudengines.mk
parent012da658a4565b60d2cae8d888fcd487c8ecfac9 (diff)
downloadmaster-31e0f0ae-95f0d4fcfdc653f7f9eb3274c1ccd21f50d2ac2e.tar.gz
master-31e0f0ae-95f0d4fcfdc653f7f9eb3274c1ccd21f50d2ac2e.tar.bz2
master-31e0f0ae-95f0d4fcfdc653f7f9eb3274c1ccd21f50d2ac2e.zip
oxnas: clean-up and improve profiles
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 49198
Diffstat (limited to 'target/linux/oxnas/profiles/cloudengines.mk')
-rw-r--r--target/linux/oxnas/profiles/cloudengines.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/oxnas/profiles/cloudengines.mk b/target/linux/oxnas/profiles/cloudengines.mk
new file mode 100644
index 0000000000..ed0a235254
--- /dev/null
+++ b/target/linux/oxnas/profiles/cloudengines.mk
@@ -0,0 +1,26 @@
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/POGOPLUG_PRO
+ NAME:=Cloud Engines Pogoplug Pro
+endef
+
+define Profile/POGOPLUG_PRO/Description
+ Profile with built-in ox820 Pogoplug Pro device-tree
+ (board with miniPCIe slot)
+endef
+
+define Profile/POGOPLUG_V3
+ NAME:=Cloud Engines Pogoplug V3
+endef
+
+define Profile/POGOPLUG_V3/Description
+ Profile with built-in ox820 Pogoplug V3 device-tree
+ (board without miniPCIe slot)
+endef
+
+$(eval $(call Profile,POGOPLUG_PRO))
+$(eval $(call Profile,POGOPLUG_V3))