summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.1
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-19 10:09:36 +0000
committerJohn Crispin <john@openwrt.org>2015-10-19 10:09:36 +0000
commit6944a9509118a3f48b3b5b4a585dee718aa75d52 (patch)
tree627f2102cd1c634ddab16c4abc8763f558021518 /target/linux/oxnas/patches-4.1
parent54b8ddf9e7cb7299d00a9e91c3bc9b2b4334e4fa (diff)
downloadmaster-31e0f0ae-6944a9509118a3f48b3b5b4a585dee718aa75d52.tar.gz
master-31e0f0ae-6944a9509118a3f48b3b5b4a585dee718aa75d52.tar.bz2
master-31e0f0ae-6944a9509118a3f48b3b5b4a585dee718aa75d52.zip
oxnas: move gmac soc glue from mach to stmmac driver
Still a lot of kernel-version ifdef'ery, but imho that's easy to remove once obsoleted and avoids duplicate code in the meantime. Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 47218
Diffstat (limited to 'target/linux/oxnas/patches-4.1')
-rw-r--r--target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch b/target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch
new file mode 100644
index 0000000000..dde3140a1f
--- /dev/null
+++ b/target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch
@@ -0,0 +1,25 @@
+--- a/drivers/net/ethernet/stmicro/stmmac/Kconfig
++++ b/drivers/net/ethernet/stmicro/stmmac/Kconfig
+@@ -20,7 +20,7 @@ config STMMAC_PLATFORM
+ ---help---
+ This selects the platform specific bus support for the stmmac driver.
+ This is the driver used on several SoCs:
+- STi, Allwinner, Amlogic Meson, Altera SOCFPGA.
++ STi, Allwinner, Amlogic Meson, Altera SOCFPGA and Oxnas.
+
+ If you have a controller with this interface, say Y or M here.
+
+--- a/drivers/net/ethernet/stmicro/stmmac/Makefile
++++ b/drivers/net/ethernet/stmicro/stmmac/Makefile
+@@ -5,8 +5,9 @@ stmmac-objs:= stmmac_main.o stmmac_ethto
+ mmc_core.o stmmac_hwtstamp.o stmmac_ptp.o $(stmmac-y)
+
+ obj-$(CONFIG_STMMAC_PLATFORM) += stmmac-platform.o
+-stmmac-platform-objs:= stmmac_platform.o dwmac-meson.o dwmac-sunxi.o \
+- dwmac-sti.o dwmac-socfpga.o dwmac-rk.o
++stmmac-platform-objs:= stmmac_platform.o dwmac-meson.o dwmac-oxnas.o \
++ dwmac-sunxi.o dwmac-sti.o dwmac-socfpga.o \
++ dwmac-rk.o
+
+ obj-$(CONFIG_STMMAC_PCI) += stmmac-pci.o
+ stmmac-pci-objs:= stmmac_pci.o