summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.0/310-oxnas-clocksource.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-21 21:47:03 +0000
committerJohn Crispin <john@openwrt.org>2015-03-21 21:47:03 +0000
commit3256194aff475c16a0804690eff105a384e7307b (patch)
tree473fd150f89a1845fe22ad28c2890ddeb4d864bb /target/linux/oxnas/patches-4.0/310-oxnas-clocksource.patch
parent908a82ab61ae1c7b09bbe5c64d8d1001db208a24 (diff)
downloadmaster-31e0f0ae-3256194aff475c16a0804690eff105a384e7307b.tar.gz
master-31e0f0ae-3256194aff475c16a0804690eff105a384e7307b.tar.bz2
master-31e0f0ae-3256194aff475c16a0804690eff105a384e7307b.zip
oxnas: add support for kernel 4.0
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 44922
Diffstat (limited to 'target/linux/oxnas/patches-4.0/310-oxnas-clocksource.patch')
-rw-r--r--target/linux/oxnas/patches-4.0/310-oxnas-clocksource.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.0/310-oxnas-clocksource.patch b/target/linux/oxnas/patches-4.0/310-oxnas-clocksource.patch
new file mode 100644
index 0000000000..73d7285af1
--- /dev/null
+++ b/target/linux/oxnas/patches-4.0/310-oxnas-clocksource.patch
@@ -0,0 +1,29 @@
+Index: linux-4.0-rc4/drivers/clocksource/Kconfig
+===================================================================
+--- linux-4.0-rc4.orig/drivers/clocksource/Kconfig
++++ linux-4.0-rc4/drivers/clocksource/Kconfig
+@@ -172,6 +172,12 @@ config VF_PIT_TIMER
+ help
+ Support for Period Interrupt Timer on Freescale Vybrid Family SoCs.
+
++config CLKSRC_RPS_TIMER
++ def_bool y if ARCH_OXNAS
++ select CLKSRC_MMIO
++ help
++ This option enables support for the oxnas rps timers.
++
+ config SYS_SUPPORTS_SH_CMT
+ bool
+
+Index: linux-4.0-rc4/drivers/clocksource/Makefile
+===================================================================
+--- linux-4.0-rc4.orig/drivers/clocksource/Makefile
++++ linux-4.0-rc4/drivers/clocksource/Makefile
+@@ -38,6 +38,7 @@ obj-$(CONFIG_CLKSRC_EFM32) += time-efm32
+ obj-$(CONFIG_CLKSRC_EXYNOS_MCT) += exynos_mct.o
+ obj-$(CONFIG_CLKSRC_SAMSUNG_PWM) += samsung_pwm_timer.o
+ obj-$(CONFIG_FSL_FTM_TIMER) += fsl_ftm_timer.o
++obj-$(CONFIG_CLKSRC_RPS_TIMER) += oxnas_rps_timer.o
+ obj-$(CONFIG_VF_PIT_TIMER) += vf_pit_timer.o
+ obj-$(CONFIG_CLKSRC_QCOM) += qcom-timer.o
+ obj-$(CONFIG_MTK_TIMER) += mtk_timer.o