summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.14/400-oxnas-nand.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-12-05 00:20:41 +0000
committerJohn Crispin <john@openwrt.org>2014-12-05 00:20:41 +0000
commite553dfc356b7087e362f0daa283239ee01ae81f5 (patch)
treef91fac0c53ff97a1c3ceabce64fb9dd62933a3d2 /target/linux/oxnas/patches-3.14/400-oxnas-nand.patch
parentdcc8a8ca9eac90b3e70104c893464c27e62daed5 (diff)
downloadmaster-31e0f0ae-e553dfc356b7087e362f0daa283239ee01ae81f5.tar.gz
master-31e0f0ae-e553dfc356b7087e362f0daa283239ee01ae81f5.tar.bz2
master-31e0f0ae-e553dfc356b7087e362f0daa283239ee01ae81f5.zip
oxnas: re-add support for kernel 3.14
This reverts commit c81ddddde5fd193802d511b42eb7b108aac17136 on https://gitorious.org/openwrt-oxnas/openwrt-oxnas.git which removed patches and config for 3.14. [arm_introduce-dma-fiq-irq-broadcast patch was renamed to match 3.18] Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43520
Diffstat (limited to 'target/linux/oxnas/patches-3.14/400-oxnas-nand.patch')
-rw-r--r--target/linux/oxnas/patches-3.14/400-oxnas-nand.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.14/400-oxnas-nand.patch b/target/linux/oxnas/patches-3.14/400-oxnas-nand.patch
new file mode 100644
index 0000000000..a5a1b02aeb
--- /dev/null
+++ b/target/linux/oxnas/patches-3.14/400-oxnas-nand.patch
@@ -0,0 +1,28 @@
+Index: linux-3.14.18/drivers/mtd/nand/Kconfig
+===================================================================
+--- linux-3.14.18.orig/drivers/mtd/nand/Kconfig
++++ linux-3.14.18/drivers/mtd/nand/Kconfig
+@@ -510,4 +510,12 @@ config MTD_NAND_XWAY
+ Enables support for NAND Flash chips on Lantiq XWAY SoCs. NAND is attached
+ to the External Bus Unit (EBU).
+
++config MTD_NAND_OXNAS
++ tristate "Support for NAND on Plxtech NAS782X SoC"
++ depends on ARCH_OXNAS
++ select MTD_NAND_PLATFORM
++ help
++ Enables support for NAND Flash chips on Plxtech NAS782X SoCs. NAND is attached
++ to the STATIC Unit.
++
+ endif # MTD_NAND
+Index: linux-3.14.18/drivers/mtd/nand/Makefile
+===================================================================
+--- linux-3.14.18.orig/drivers/mtd/nand/Makefile
++++ linux-3.14.18/drivers/mtd/nand/Makefile
+@@ -49,5 +49,6 @@ obj-$(CONFIG_MTD_NAND_JZ4740) += jz4740
+ obj-$(CONFIG_MTD_NAND_GPMI_NAND) += gpmi-nand/
+ obj-$(CONFIG_MTD_NAND_XWAY) += xway_nand.o
+ obj-$(CONFIG_MTD_NAND_BCM47XXNFLASH) += bcm47xxnflash/
++obj-$(CONFIG_MTD_NAND_OXNAS) += oxnas_nand.o
+
+ nand-objs := nand_base.o nand_bbt.o