summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.14/340-oxnas-pcie.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-12-05 00:20:41 +0000
committerJohn Crispin <john@openwrt.org>2014-12-05 00:20:41 +0000
commite553dfc356b7087e362f0daa283239ee01ae81f5 (patch)
treef91fac0c53ff97a1c3ceabce64fb9dd62933a3d2 /target/linux/oxnas/patches-3.14/340-oxnas-pcie.patch
parentdcc8a8ca9eac90b3e70104c893464c27e62daed5 (diff)
downloadmaster-31e0f0ae-e553dfc356b7087e362f0daa283239ee01ae81f5.tar.gz
master-31e0f0ae-e553dfc356b7087e362f0daa283239ee01ae81f5.tar.bz2
master-31e0f0ae-e553dfc356b7087e362f0daa283239ee01ae81f5.zip
oxnas: re-add support for kernel 3.14
This reverts commit c81ddddde5fd193802d511b42eb7b108aac17136 on https://gitorious.org/openwrt-oxnas/openwrt-oxnas.git which removed patches and config for 3.14. [arm_introduce-dma-fiq-irq-broadcast patch was renamed to match 3.18] Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43520
Diffstat (limited to 'target/linux/oxnas/patches-3.14/340-oxnas-pcie.patch')
-rw-r--r--target/linux/oxnas/patches-3.14/340-oxnas-pcie.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.14/340-oxnas-pcie.patch b/target/linux/oxnas/patches-3.14/340-oxnas-pcie.patch
new file mode 100644
index 0000000000..ca0ccb83c8
--- /dev/null
+++ b/target/linux/oxnas/patches-3.14/340-oxnas-pcie.patch
@@ -0,0 +1,23 @@
+Index: linux-3.14.18/drivers/pci/host/Kconfig
+===================================================================
+--- linux-3.14.18.orig/drivers/pci/host/Kconfig
++++ linux-3.14.18/drivers/pci/host/Kconfig
+@@ -33,4 +33,9 @@ config PCI_RCAR_GEN2
+ There are 3 internal PCI controllers available with a single
+ built-in EHCI/OHCI host controller present on each one.
+
++config PCI_OXNAS
++ bool "PLX Oxnas PCIe controller"
++ depends on ARCH_OXNAS
++ select PCIEPORTBUS
++
+ endmenu
+Index: linux-3.14.18/drivers/pci/host/Makefile
+===================================================================
+--- linux-3.14.18.orig/drivers/pci/host/Makefile
++++ linux-3.14.18/drivers/pci/host/Makefile
+@@ -4,3 +4,4 @@ obj-$(CONFIG_PCI_IMX6) += pci-imx6.o
+ obj-$(CONFIG_PCI_MVEBU) += pci-mvebu.o
+ obj-$(CONFIG_PCI_TEGRA) += pci-tegra.o
+ obj-$(CONFIG_PCI_RCAR_GEN2) += pci-rcar-gen2.o
++obj-$(CONFIG_PCI_OXNAS) += pcie-oxnas.o