summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.14/330-oxnas-pinctrl.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-12-05 00:20:41 +0000
committerJohn Crispin <john@openwrt.org>2014-12-05 00:20:41 +0000
commite553dfc356b7087e362f0daa283239ee01ae81f5 (patch)
treef91fac0c53ff97a1c3ceabce64fb9dd62933a3d2 /target/linux/oxnas/patches-3.14/330-oxnas-pinctrl.patch
parentdcc8a8ca9eac90b3e70104c893464c27e62daed5 (diff)
downloadmaster-31e0f0ae-e553dfc356b7087e362f0daa283239ee01ae81f5.tar.gz
master-31e0f0ae-e553dfc356b7087e362f0daa283239ee01ae81f5.tar.bz2
master-31e0f0ae-e553dfc356b7087e362f0daa283239ee01ae81f5.zip
oxnas: re-add support for kernel 3.14
This reverts commit c81ddddde5fd193802d511b42eb7b108aac17136 on https://gitorious.org/openwrt-oxnas/openwrt-oxnas.git which removed patches and config for 3.14. [arm_introduce-dma-fiq-irq-broadcast patch was renamed to match 3.18] Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43520
Diffstat (limited to 'target/linux/oxnas/patches-3.14/330-oxnas-pinctrl.patch')
-rw-r--r--target/linux/oxnas/patches-3.14/330-oxnas-pinctrl.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.14/330-oxnas-pinctrl.patch b/target/linux/oxnas/patches-3.14/330-oxnas-pinctrl.patch
new file mode 100644
index 0000000000..60caca361d
--- /dev/null
+++ b/target/linux/oxnas/patches-3.14/330-oxnas-pinctrl.patch
@@ -0,0 +1,32 @@
+Index: linux-3.14.18/drivers/pinctrl/Kconfig
+===================================================================
+--- linux-3.14.18.orig/drivers/pinctrl/Kconfig
++++ linux-3.14.18/drivers/pinctrl/Kconfig
+@@ -87,6 +87,15 @@ config PINCTRL_AT91
+ help
+ Say Y here to enable the at91 pinctrl driver
+
++config PINCTRL_OXNAS
++ bool "OXNAS pinctrl driver"
++ depends on OF
++ depends on ARCH_OXNAS
++ select PINMUX
++ select PINCONF
++ help
++ Say Y here to enable the oxnas pinctrl driver
++
+ config PINCTRL_BAYTRAIL
+ bool "Intel Baytrail GPIO pin control"
+ depends on GPIOLIB && ACPI && X86
+Index: linux-3.14.18/drivers/pinctrl/Makefile
+===================================================================
+--- linux-3.14.18.orig/drivers/pinctrl/Makefile
++++ linux-3.14.18/drivers/pinctrl/Makefile
+@@ -67,6 +67,7 @@ obj-$(CONFIG_PINCTRL_LANTIQ) += pinctrl-
+ obj-$(CONFIG_PINCTRL_TB10X) += pinctrl-tb10x.o
+ obj-$(CONFIG_PINCTRL_ST) += pinctrl-st.o
+ obj-$(CONFIG_PINCTRL_VF610) += pinctrl-vf610.o
++obj-$(CONFIG_PINCTRL_OXNAS) += pinctrl-oxnas.o
+
+ obj-$(CONFIG_PLAT_ORION) += mvebu/
+ obj-$(CONFIG_ARCH_SHMOBILE) += sh-pfc/