summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-09 12:16:04 +0000
committerJohn Crispin <john@openwrt.org>2015-02-09 12:16:04 +0000
commitba1904056dd9105fe668a338336a2aa5b5d9a5b0 (patch)
treec50063c82739be7fb494dca8122bd9f834919481 /target/linux/oxnas/image
parent4ce7053b2b811b1a0055fc0f9d51a04e63ee8092 (diff)
downloadmaster-31e0f0ae-ba1904056dd9105fe668a338336a2aa5b5d9a5b0.tar.gz
master-31e0f0ae-ba1904056dd9105fe668a338336a2aa5b5d9a5b0.tar.bz2
master-31e0f0ae-ba1904056dd9105fe668a338336a2aa5b5d9a5b0.zip
oxnas: copy ubinized images to binary folder
Since r43778 ubinized images are stored inside KDIR. This makes sense when using an uninized image to generate a factory image. On oxnas ubinized images were used for sysupgrade before proper NAND support was implemented in OpenWrt. For users still on old builds before sysupgrade.tar was introduced, ubinized image is thus the only option to conveniantly upgrade to a more recent build. Copy ubinized image also to BIN_DIR, so it will be easier for users to find them. Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 44357
Diffstat (limited to 'target/linux/oxnas/image')
-rw-r--r--target/linux/oxnas/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/oxnas/image/Makefile b/target/linux/oxnas/image/Makefile
index a3dae16f76..b09c67ef36 100644
--- a/target/linux/oxnas/image/Makefile
+++ b/target/linux/oxnas/image/Makefile
@@ -89,6 +89,7 @@ endef
define Image/Build/squashfs
$(call Image/Build/SysupgradeNAND,$(call sanitize_profile_name),$(1),$(KDIR)/fit-$(call sanitize_profile_name).itb)
$(call Image/Build/UbinizeImage,$(call sanitize_profile_name),--uboot-env --kernel $(KDIR)/fit-$(call sanitize_profile_name).itb,$(1),$($(PROFILE)_UBI_OPTS))
+ cp $(KDIR)/$(IMG_PREFIX)-$(call sanitize_profile_name)-squashfs-ubinized.bin $(BIN_DIR)
endef
define Image/mkfs/targz
@@ -101,6 +102,7 @@ define Image/Build/ubifs
ifneq ($($(PROFILE)_UBIFS_OPTS),)
$(call Image/Build/SysupgradeNAND,$(call sanitize_profile_name),ubifs,$(KDIR)/fit-$(call sanitize_profile_name).itb)
$(call Image/Build/UbinizeImage,$(call sanitize_profile_name),--uboot-env --kernel $(KDIR)/fit-$(call sanitize_profile_name).itb,ubifs,$($(PROFILE)_UBI_OPTS))
+ cp $(KDIR)/$(IMG_PREFIX)-$(call sanitize_profile_name)-ubifs-ubinized.bin $(BIN_DIR)
endif
endef