summaryrefslogtreecommitdiffstats
path: root/target/linux/orion
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-10-29 09:55:20 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-10-29 09:55:20 +0000
commit8e49dfe68a13908c8628ba40c621c2d35b308745 (patch)
tree8dbf2c7225e055c06fbe45c354ebfab39710b166 /target/linux/orion
parentf7b2089704cf962bb4c02290727a8fd41f9e587b (diff)
downloadmaster-31e0f0ae-8e49dfe68a13908c8628ba40c621c2d35b308745.tar.gz
master-31e0f0ae-8e49dfe68a13908c8628ba40c621c2d35b308745.tar.bz2
master-31e0f0ae-8e49dfe68a13908c8628ba40c621c2d35b308745.zip
the uImage's filename will hardly change
SVN-Revision: 33985
Diffstat (limited to 'target/linux/orion')
-rw-r--r--target/linux/orion/image/generic.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/target/linux/orion/image/generic.mk b/target/linux/orion/image/generic.mk
index 9187b569a0..f4319e0b6c 100644
--- a/target/linux/orion/image/generic.mk
+++ b/target/linux/orion/image/generic.mk
@@ -18,7 +18,6 @@ KERNEL_MTD_SIZE:=1024
# Netgear WNR854T: erase size is 128KiB = 0x00020000 = 131072
ERASE_SIZE_128K:=128
-UIMAGE_FILE_NAME_WNR854T:=uImage
# Linksys WRT350N v2: erase size is 64KiB = 0x00010000 = 65536
ERASE_SIZE_64K:=64
@@ -48,7 +47,7 @@ define Image/BuildKernel
$(call Image/BuildKernel/ARM/zImage,wn802t,"\x0c\x1c\xa0\xe3\xea\x10\x81\xe3")
$(call Image/BuildKernel/ARM/uImage,wn802t)
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y) # nothing more to do for a ramdisk build
-$(call Image/BuildKernel/JFFS2uImage,wn802t,$(ERASE_SIZE_64K),$(UIMAGE_FILE_NAME_WNR854T))
+$(call Image/BuildKernel/JFFS2uImage,wn802t,$(ERASE_SIZE_64K),uImage)
$(call Image/Default/FileSizeCheck,$(KDIR)/wn802t-uImage.jffs2,$(shell expr $(KERNEL_MTD_SIZE) \* 1024))
endif
@@ -56,7 +55,7 @@ $(call Image/Default/FileSizeCheck,$(KDIR)/wn802t-uImage.jffs2,$(shell expr $(KE
$(call Image/BuildKernel/ARM/zImage,wnr854t,"\x07\x1c\xa0\xe3\x09\x10\x81\xe3")
$(call Image/BuildKernel/ARM/uImage,wnr854t)
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y) # nothing more to do for a ramdisk build
-$(call Image/BuildKernel/JFFS2uImage,wnr854t,$(ERASE_SIZE_128K),$(UIMAGE_FILE_NAME_WNR854T))
+$(call Image/BuildKernel/JFFS2uImage,wnr854t,$(ERASE_SIZE_128K),uImage)
$(call Image/Default/FileSizeCheck,$(KDIR)/wnr854t-uImage.jffs2,$(shell expr $(KERNEL_MTD_SIZE) \* 1024))
endif