summaryrefslogtreecommitdiffstats
path: root/target/linux/orion
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-06-05 06:17:12 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-06-05 06:17:12 +0000
commit28e8b8dc054a60434568f2bd439e111ab1d2aff6 (patch)
tree5aceacd8b8abcd428d24648dd1d7c25b64c67a21 /target/linux/orion
parente161581d45e97bbd6b63648c7513eeed2ea42e7c (diff)
downloadmaster-31e0f0ae-28e8b8dc054a60434568f2bd439e111ab1d2aff6.tar.gz
master-31e0f0ae-28e8b8dc054a60434568f2bd439e111ab1d2aff6.tar.bz2
master-31e0f0ae-28e8b8dc054a60434568f2bd439e111ab1d2aff6.zip
only copy uImages to the bin dir on ramdisk builds
SVN-Revision: 36851
Diffstat (limited to 'target/linux/orion')
-rw-r--r--target/linux/orion/image/generic.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/orion/image/generic.mk b/target/linux/orion/image/generic.mk
index c3aa50f01c..19daaf647a 100644
--- a/target/linux/orion/image/generic.mk
+++ b/target/linux/orion/image/generic.mk
@@ -82,7 +82,9 @@ define Image/BuildKernel/ARM/uImage
'$(STAGING_DIR_HOST)/bin/mkimage' -A arm -O linux -T kernel \
-C none -a 0x00008000 -e 0x00008000 -n 'Linux-$(LINUX_VERSION)' \
-d '$(KDIR)/$(1)-zImage' '$(KDIR)/$(1)-uImage'
+ ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y) # only copy uImage for ramdisk build
cp '$(KDIR)/$(1)-uImage' '$(BIN_DIR)/openwrt-$(1)-uImage'
+ endif
endef
define Image/BuildKernel/JFFS2uImage