summaryrefslogtreecommitdiffstats
path: root/target/linux/orion/patches
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2009-03-22 12:38:24 +0000
committerRod Whitby <rod@whitby.id.au>2009-03-22 12:38:24 +0000
commitf11f903b616c48cd22ee183fc11ca3173ef01502 (patch)
tree79bd424285736dd4a2f9d1ffa06f25da009e6a89 /target/linux/orion/patches
parente6b22c5fe28c625f8bf2f8cdf899165320a3d570 (diff)
downloadmaster-31e0f0ae-f11f903b616c48cd22ee183fc11ca3173ef01502.tar.gz
master-31e0f0ae-f11f903b616c48cd22ee183fc11ca3173ef01502.tar.bz2
master-31e0f0ae-f11f903b616c48cd22ee183fc11ca3173ef01502.zip
orion: Added initial support for Freecom DT2. Thanks to Zintis.
SVN-Revision: 14963
Diffstat (limited to 'target/linux/orion/patches')
-rw-r--r--target/linux/orion/patches/200-dt2_board_support.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/orion/patches/200-dt2_board_support.patch b/target/linux/orion/patches/200-dt2_board_support.patch
new file mode 100644
index 0000000000..bf82ed760c
--- /dev/null
+++ b/target/linux/orion/patches/200-dt2_board_support.patch
@@ -0,0 +1,26 @@
+diff -ruN linux-2.6.28.5.orig/arch/arm/mach-orion5x/Kconfig linux-2.6.28.5/arch/arm/mach-orion5x/Kconfig
+--- linux-2.6.28.5.orig/arch/arm/mach-orion5x/Kconfig 2009-02-21 00:41:27.000000000 +0200
++++ linux-2.6.28.5/arch/arm/mach-orion5x/Kconfig 2009-02-28 10:06:24.000000000 +0200
+@@ -16,6 +16,13 @@
+ Say 'Y' here if you want your kernel to support the
+ Marvell Orion-NAS (88F5182) RD2
+
++config MACH_DT2
++ bool "Freecom DataTank Gateway"
++ select I2C_BOARDINFO
++ help
++ Say 'Y' here if you want your kernel to support the
++ Freecom DataTank Gateway
++
+ config MACH_KUROBOX_PRO
+ bool "KuroBox Pro"
+ select I2C_BOARDINFO
+diff -ruN linux-2.6.28.5.orig/arch/arm/mach-orion5x/Makefile linux-2.6.28.5/arch/arm/mach-orion5x/Makefile
+--- linux-2.6.28.5.orig/arch/arm/mach-orion5x/Makefile 2009-02-21 00:41:27.000000000 +0200
++++ linux-2.6.28.5/arch/arm/mach-orion5x/Makefile 2009-02-28 10:07:35.000000000 +0200
+@@ -17,3 +17,4 @@
+ obj-$(CONFIG_MACH_RD88F5181L_GE) += rd88f5181l-ge-setup.o
+ obj-$(CONFIG_MACH_RD88F5181L_FXO) += rd88f5181l-fxo-setup.o
+ obj-$(CONFIG_MACH_RD88F6183AP_GE) += rd88f6183ap-ge-setup.o
++obj-$(CONFIG_MACH_DT2) += dt2-setup.o
+